joaonetto marked an inline comment as done. joaonetto added a comment.
In my opinion is better to have it this way, I guess most users don't know about the newline. Do you have an opinion in this @ngraham ? INLINE COMMENTS > aacid wrote in textpage.cpp:865 > strNotUsed seems like a weird variable name given you actually use it the two > following names. > > Would something like origStr or something make more sense? Yes, I will make it origStr, it is better. Unfortunately curEntity->text() needs a const variable. I would put it in str, but it would mess up the stringLenghtAdaptedWithHyphen. > aacid wrote in textpage.cpp:866 > given that you're modifying this line, make len const :) > > Also are you totally sure this needs to be over strNotUsed and not str? Hmmm > i guess it works both ways since str is the same length as strNotUsed I need it to be strNotUsed because I'm making str const, and I'm replacing the '\n' as soon as I create it. It would mess up the stringLenghtAdaptedWithHyphen because it would have the "-\n" text entities as " " REPOSITORY R223 Okular REVISION DETAIL https://phabricator.kde.org/D19717 To: joaonetto, #okular Cc: aacid, ngraham, okular-devel, joaonetto, tfella, darcyshen