> On Sep 21, 2016, at 2:40 PM, Geoff Nordli <geo...@gnaa.net> wrote:
> 
> Hi.
> 
> When I try to upgrade to r151018 from r151016 it can't complete.
> 
> #pkg update
> Creating Plan (Checking for conflicting actions): /
> pkg update: The following packages deliver conflicting action types to 
> usr/share/man/man4/ssh_config.4:
> 
>  link:
> pkg://omnios/service/network/ssh-common@0.5.11,5.11-0.151018:20160603T032215Z
>  file:
> pkg://omnios/network/openssh@7.2.2,5.11-0.151018:20160412T153954Z
> 
> These packages may not be installed together. Any non-conflicting set may
> be, or the packages must be corrected before they can be installed.
> 
> The following packages all deliver file actions to etc/ssh/ssh_config:
> 
> pkg://omnios/network/openssh@7.2.2,5.11-0.151018:20160412T153954Z
> pkg://omnios/service/network/ssh-common@0.5.11,5.11-0.151018:20160603T032215Z
> 
> These packages may not be installed together. Any non-conflicting set may
> be, or the packages must be corrected before they can be installed.

Add these flags to the 'pkg upgrade' command:

        --reject network/ssh-common --reject service/network/ssh --reject 
omnios/network/ssh --reject ssh/ssh-key

which will convert you from SunSSH to OpenSSH (which is good, because SunSSH 
goes away after r151018).

Dan

_______________________________________________
OmniOS-discuss mailing list
OmniOS-discuss@lists.omniti.com
http://lists.omniti.com/mailman/listinfo/omnios-discuss

Reply via email to