All --

Unless someone has a strong reason for keeping support for GCC 4.4.7 (i.e., the 
default GCC compiler that shipped in RHEL 6), Open MPI is going to drop support 
for it in v5.0.0.

The reason for this is that PRTE and PMIX no longer compile successfully with 
GCC 4.4.7 (and Open MPI gets a lot of compiler warnings with GCC 4.4.7).  These 
packages ***could be updated to support GCC 4.4.7 if someone cares***.  But 
we'll need someone to contribute pull requests to do so.

If no one plans to contribute pull requests for this in the near future, we're 
doing to drop support for GCC 4.4.7 in Open MPI v5.0.0.  See

* Note that RHEL 7 ships with GCC v4.8.5.
* The Open MPI community regularly tests with GCC v4.8.1.

Hence, Open MPI >= v5.0.0 will support GCC >= v4.8.1.  Specifically: Open MPI's 
configure script will abort with helpful error message for versions of GCC < 

Finally, note that this announcement is solely about Open MPI >= v5.0.0.  The 
Open MPI v4.0.x and v4.1.x series will continue to support GCC 4.4.7.

Jeff Squyres

ompi-packagers mailing list

Reply via email to