ok, thank you very much,I just solved it in the afternoon, but there is a
new problem, check snk vm, but the traffic does not produce, do you know
what might be the reason?

 



 

发件人: FREEMAN, BRIAN D <bf1...@att.com> 
发送时间: 2018年7月11日 20:50
收件人: onap-discuss@lists.onap.org; zhehuang_...@163.com
抄送: huangzh.bri <huangzh....@chinatelecom.cn>
主题: RE: [onap-discuss] [integration] execute closedloop script,get
"TypeError: string indices must be integers"

 

Hard to debug remotely but it might be that you haven’t configured robot
correctly. If the vFWSNK-1 does not exist you should get the below error
message.

Instead you are getting a python error which could mean the VNF  exists in
AAI but the vfModule or one of the relationships does not.

 

I would go to the robot gui and look up your test to see the data you are
getting back and where in
/var/opt/OpenECOMP_ETE/robot/resources/demo_preload.robot

you are getting the error from.

 

In heat if you run demo.sh init_robot and set a password for user ‘test’
you can then go to the robot VM on port 88 and view logs

(e.g. http://10.12.5.220:88/logs/) 

 

Scroll down to the test run (PreloadDemo in this case)  and then look at
log.html

 

You can also find the logs on the VM file system but its easier to use the
web interface.

 

Brian

 

 

 

 

root@onap-robot:/opt# ./demo.sh preload vFWSNK-1 vFWSNK-Module-1

Starting Xvfb on display :89 with res 1280x1024x24

Executing robot tests at log level TRACE

============================================================================
==

OpenECOMP ETE


============================================================================
==

OpenECOMP ETE.Robot


============================================================================
==

OpenECOMP ETE.Robot.Testsuites


============================================================================
==

OpenECOMP ETE.Robot.Testsuites.Demo :: Executes the VNF Orchestration Test
...

============================================================================
==

Preload VNF                                                           | FAIL
|

VNF Name: vFWSNK-1 is not found.

----------------------------------------------------------------------------
--

OpenECOMP ETE.Robot.Testsuites.Demo :: Executes the VNF Orchestrat... | FAIL
|

1 critical test, 0 passed, 1 failed

1 test total, 0 passed, 1 failed

============================================================================
==

OpenECOMP ETE.Robot.Testsuites                                        | FAIL
|

1 critical test, 0 passed, 1 failed

1 test total, 0 passed, 1 failed

============================================================================
==

OpenECOMP ETE.Robot                                                   | FAIL
|

1 critical test, 0 passed, 1 failed

1 test total, 0 passed, 1 failed

============================================================================
==

OpenECOMP ETE                                                         | FAIL
|

1 critical test, 0 passed, 1 failed

1 test total, 0 passed, 1 failed

============================================================================
==

Output:  /share/logs/demo/PreloadDemo/output.xml

Log:     /share/logs/demo/PreloadDemo/log.html

Report:  /share/logs/demo/PreloadDemo/report.html

 

From: onap-discuss@lists.onap.org <mailto:onap-discuss@lists.onap.org>
<onap-discuss@lists.onap.org <mailto:onap-discuss@lists.onap.org> > On
Behalf Of zhehuang_...@163.com <mailto:zhehuang_...@163.com> 
Sent: Tuesday, July 10, 2018 10:03 PM
To: onap-discuss <onap-discuss@lists.onap.org
<mailto:onap-discuss@lists.onap.org> >
Cc: huangzh.bri <huangzh....@chinatelecom.cn
<mailto:huangzh....@chinatelecom.cn> >
Subject: [onap-discuss] [integration] execute closedloop script,get
"TypeError: string indices must be integers"

 

Execute the closedloop script of the vfw scene. When loading data, execute:
root@onap-robot:/opt# ./demo.sh preload vFWSNK-1 vFWSNK-Module-1, error:
TypeError: string indices must be integers, who know What is the reason? I
searched all vfw related scripts but didn't find this error. Thank you

 

root@onap-robot:/opt# ./demo.sh preload vFWSNK-1 vFWSNK-Module-1

Starting Xvfb on display :89 with res 1280x1024x24

Executing robot tests at log level TRACE

============================================================================
==

OpenECOMP ETE

============================================================================
==

OpenECOMP ETE.Robot

============================================================================
==

OpenECOMP ETE.Robot.Testsuites

============================================================================
==

OpenECOMP ETE.Robot.Testsuites.Demo :: Executes the VNF Orchestration Test
...

============================================================================
==

Preload VNF                                                           | FAIL
|

TypeError: string indices must be integers

----------------------------------------------------------------------------
--

OpenECOMP ETE.Robot.Testsuites.Demo :: Executes the VNF Orchestrat... | FAIL
|

1 critical test, 0 passed, 1 failed

1 test total, 0 passed, 1 failed

============================================================================
==

OpenECOMP ETE.Robot.Testsuites                                        | FAIL
|

1 critical test, 0 passed, 1 failed

1 test total, 0 passed, 1 failed

============================================================================
==

OpenECOMP ETE.Robot                                                   | FAIL
|

1 critical test, 0 passed, 1 failed

1 test total, 0 passed, 1 failed

============================================================================
==

OpenECOMP ETE                                                         | FAIL
|

1 critical test, 0 passed, 1 failed

1 test total, 0 passed, 1 failed

============================================================================
==

Output:  /share/logs/demo/PreloadDemo/output.xml

Log:     /share/logs/demo/PreloadDemo/log.html

Report:  /share/logs/demo/PreloadDemo/report.html

root@onap-robot:/opt#

 

  _____

zhehuang_...@163.com <mailto:zhehuang_...@163.com> 




-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.

View/Reply Online (#11021): https://lists.onap.org/g/onap-discuss/message/11021
Mute This Topic: https://lists.onap.org/mt/23245071/21656
Group Owner: onap-discuss+ow...@lists.onap.org
Unsubscribe: https://lists.onap.org/g/onap-discuss/unsub  
[arch...@mail-archive.com]
-=-=-=-=-=-=-=-=-=-=-=-

Reply via email to