Bill Erickson said the following on 05/05/2008 12:21 PM:
On Monday 05 May 2008 11:03 Bill Ott wrote:
I've set my test self-check machine back up and was running it through
its paces.  I'm using basically the example oils_sip.xml config file,
and the RAW transport.

All starts out well, but upon checkout, I receive the following.  The
item is checked out, but the ACS session promptly dies.


At the console of the SIPServer, I see:
   Item config script [ARRAY(0x2b4c1a0) : circ/circ_item_config.js]
failed to run: Error: ReferenceError: ff_pos is not defined at line 9:
(null)
   Can't use string ("0") as a HASH ref while "strict refs" in use at
/openils/lib/perl5/OpenILS/SIP/Item.pm line 115.

Hi Bill,

I committed a fix to the default config this weekend to resolve this issue. In the <scripts> section toward the bottom of oils_sip.xml, you will need to add an additional script path and restart SIP:

<path>/openils/var/catalog/</path>

Let me know if that takes care of it.

As usual, you're one step ahead of me.  Works perfect, thanks!


Reply via email to