Hi, all.

I work with John at C/W MARS and just informed him of the issue.

In this specific case, the fund transfer is failing because the funding
source for the originating fund has no credits.

The database function, acq.transfer_fund, requires there to be credits
on the originating fund. If there are none, then no transfer takes place.

This is a silent failure as the credits are used in a loop, so if there
are no credits, then the loop is never entered. The transfer happens in
the loop. Is this a bug? I don't know, but you think so, maybe head to
Launchpad and say so.

Jason

On 02/13/2017 03:43 PM, John Amundson wrote:
> Hi, Kathy:
> 
> Thank you for your reply.
> 
> - the Evergeen documentation
> here, http://docs.evergreen-ils.org/2.10/_funds.html, states that the
> fund location is under server admin, but I found it directly under
> acquisitions admin in our 2.10 client, which is where I believe it
> should be.
> 
> - After some testing with permissions, this does not seem to be the
> issue. However, I discovered that I only have issues moving money
> from/to funds for the library in question, (it is a branch system), but
> I do not have any issues transferring money for funds for other
> libraries, including another library branch system. I'm in the process
> of looking through the funds to see if anything seems out of place, but
> nothing catches my eye yet.
> 
> John
> 
> *John Amundson*_
> _Library Applications Associate II
> C/W MARS, Inc.
> jamund...@cwmars.org <mailto:jamund...@cwmars.org>
> (508) 755-3323 <tel:%28508%29%20755-3323> ext 322
> 
> 
> On Mon, Feb 13, 2017 at 1:42 PM, Kathy Lussier <kluss...@masslnc.org
> <mailto:kluss...@masslnc.org>> wrote:
> 
>     Hi John,
> 
>     I didn't have a 2.10 server handy to test this workflow, but I just
>     tested it on master, and it worked for me. I created a screencast at
>     https://drive.google.com/file/d/0B74gDMUDwDXqT2kzRXp5VGtTbFE/view
>     <https://drive.google.com/file/d/0B74gDMUDwDXqT2kzRXp5VGtTbFE/view>
>     just in case you see anything obvious in your steps that you might
>     have missed. Based on what you sent, it sounds like you followed
>     each of the steps correctly.
> 
>     A couple of thoughts came to mind:
> 
>     - It seemed strange that you had to go to Server Admin to get to the
>     acq admin menu rather than going directly to Acq Admin from the main
>     admin menu. Do you know if your client is up to date with the
>     version of Evergreen you're running?
> 
>     - Do you know for sure that your account has permission to transfer
>     funds? I didn't try this workflow to see what happened with an
>     account that does not have permission, but I know the client often
>     does not give good feedback when it's a permissions issue.
> 
>     Kathy
> 
> 
>     On 02/13/2017 01:14 PM, John Amundson wrote:
>>     Hi, Everyone:
>>
>>     I am on EG 2.10.7, and I'm trying to transfer money from one fund
>>     to another, and it does not seem to be working. I'm following the
>>     rules laid out in the Evergreen Documentation for 2.10:
>>
>>      1. To access funds, click /Admin → Server Administration →
>>         Acquisitions → Funds/. (note: I believe this should be Admin >
>>         Acquisitions Administration > Funds)
>>      2. Click the hyperlinked name of the originating fund.
>>      3. The Fund Details screen appears. Click Transfer Money.
>>      4. Enter the amount that you would like to transfer.
>>      5. From the drop-down menu, select the destination fund.
>>      6. Add a note. This field is optional.
>>      7. Click /Transfer/.
>>
>>     When I try to transfer money, (I'm trying to transfer $500.00 and
>>     have not tried another amount), the screen will reload as if
>>     something happened, but when it comes back, the change in money is
>>     not reflected in the fund. It is also not seen in the destination
>>     fund.
>>
>>     It does not appear that transferring money is working for me.
>>
>>     NOTE: I am still relatively new to the Acquisitions function, so
>>     any help anyone can provide is appreciated.
>>
>>     Thank you!
>>
>>     John
>>
>>     *John Amundson*_
>>     _Library Applications Associate II
>>     C/W MARS, Inc.
>>     jamund...@cwmars.org <mailto:jamund...@cwmars.org>
>>     (508) 755-3323 <tel:%28508%29%20755-3323> ext 322
>>
> 
>     -- 
>     Kathy Lussier
>     Project Coordinator
>     Massachusetts Library Network Cooperative
>     (508) 343-0128 <tel:(508)%20343-0128>
>     kluss...@masslnc.org <mailto:kluss...@masslnc.org>
>     Twitter: http://www.twitter.com/kmlussier 
> <http://www.twitter.com/kmlussier>
> 
> 

Reply via email to