Hi all,

At the developer's meeting earlier this month, with a follow-up discussion on the open-ils-dev list, the developers decided on the following requirements for Postgres support in Evergreen:

- For the 2.12 release (scheduled for tomorrow), deprecate Postgres 9.3 support and recommend use of Postgres 9.4.

- For the 3.0 release (September), make Postgres 9.4 a minimum requirement.

A primary reason for this recommendation is an upcoming search development project, expected to be done for the 3.0 release, that will require database functions only available in 9.4+. The goal of this work is to eliminate two-stage search from Evergreen, leading to a more complete set of search results. Early analysis has also shown that we will see performance improvements with this work, particularly with more selective searches.

Postgres 9.4 has been in release since December 2014 and is already used successfully in production at many Evergreen sites. The new requirement will not impact any Evergreen releases prior to the 2.12 release. Any new features that depend on 9.4 will only make an appearance in Evergreen 3.0 or later.

Feel free to let us know if you have any questions!

Kathy Lussier
Project Coordinator
Massachusetts Library Network Cooperative
(508) 343-0128
Twitter: http://www.twitter.com/kmlussier

Reply via email to