To all,

I'm working through the installation of a fresh EG 2.12.1/OpenSRF 2.5.0 setup but I'm having problems at the 'make' stage of EG 2.12.1. I keep getting a missing library error: cannot find -ldbdpgsql. Everything up to there seems to run fine (a few warnings here and there, but they all appear to be minor in nature: variables set but not used, pointers set to -1).

I've run through the process a couple of times now and I always get stuck at the same spot. On my first attempt, I used the built-in Ubuntu 9.5 Postgres server (even though the EG developers recommend 9.4). Thinking that might be the problem, I started over again and installed Postgres 9.4, only to arrive at the same error.

Then I thought that a dependency wasn't quite right in the make file, I tried manually running:

        apt-get install lib-dbdpgsql

and I'm told it's already installed and the newest version available, so it seems I've got the library on the system. I'm guessing the system just isn't referencing it in the correct location.

Can anyone provide any input on where I might be going wrong and how I can fix it?

Thanks in advance!

Reply via email to