Ben,

You gave me the clue I needed. I had mistakenly been toying with the 32-bit version of Xenial 16.04.2. I've installed the 64-bit version and I'm past that error.

Thanks for the guidance!  And I'll be carrying on with Postgres 9.5...

Hi Garry,

Hmm, sounds like you've got a minor mystery there.  That sort of
library error sounds like a bad path or missing library to me.

Some background questions if I might start with:

Can you confirm which Linux distribution you are using?  The title of
your email says Ubuntu Xenial, but to confirm you're using the 64-bit
server edition for Ubuntu 16.04 Xenial?

I build with the stock Makefile.install dependencies which includes
client stuff for PostgreSQL 9.5 by default for xenial, so there
shouldn't be a need to downgrade that to 9.4 despite what the README
suggests as the minimum.

I might also confirm that you are going through the OpenSRF 2.5.0
installation first, having a confirmed working OpenSRF install, and
then proceeding with the Evergreen installation (running pre-reqs
there, etc. too).  Some steps look similar between Evergreen and
OpenSRF and people think they already did it and skip, but they are
two separate install procedures and steps repeat occasionally.

Will ponder further on the subject.

-- Ben

On Thu, May 11, 2017 at 12:54 PM, Garry Dunn <ga...@trellisconsulting.ca> wrote:
To all,

I'm working through the installation of a fresh EG 2.12.1/OpenSRF 2.5.0
setup but I'm having problems at the 'make' stage of EG 2.12.1.  I keep
getting a missing library error:  cannot find -ldbdpgsql.  Everything up to
there seems to run fine (a few warnings here and there, but they all appear
to be minor in nature: variables set but not used, pointers set to -1).

I've run through the process a couple of times now and I always get stuck at
the same spot.  On my first attempt, I used the built-in Ubuntu 9.5 Postgres
server (even though the EG developers recommend 9.4). Thinking that might be
the problem, I started over again and installed Postgres 9.4, only to arrive
at the same error.

Then I thought that a dependency wasn't quite right in the make file, I
tried manually running:

        apt-get install lib-dbdpgsql

and I'm told it's already installed and the newest version available, so it
seems I've got the library on the system.  I'm guessing the system just
isn't referencing it in the correct location.

Can anyone provide any input on where I might be going wrong and how I can
fix it?

Thanks in advance!



--
Benjamin Shum
Evergreener


--
Garry Dunn, P. Eng.
Trellis Consulting
Cell: 905-302-7273
Office: 705-835-5608

Reply via email to