Disregard - I went ahead and re-purged it and re-installed postgres and the
socket is there, and it is letting me proceed as expected. Sorry for the
waste of time.

For those that run into the same issue-
as root
sudo apt-get remove --purge postgresql-[version#]
sudo apt-get install postgresql-[version#]
/etc/init.d/postgresql stop
/etc/init.d/postgresql start
cd to /var/run/postgresql/
verify .s.PGSQL.5432 is present with a ls -la

-Jon

On Wed, Sep 12, 2018 at 5:46 PM JonGeorg SageLibrary <
jongeorg.sagelibr...@gmail.com> wrote:

> Greetings again,
> So I've gotten as far as step 13.1 on
> https://evergreen-ils.org/documentation/install/README_3_1.html#__configure_the_apache_web_server
>
> I'm at the step of creating the evergreen user *createuser -s -P
> evergreen* - but each time I get an error---
> createuser: could not connect to database postgres: could not connect to
> server: No such file or directory
>         Is the server running locally and accepting
>         connections on Unix domain socket
> "/var/run/postgresql/.s.PGSQL.5432"?
>
> looking at /var/run/postgresql/ there is in fact no .s.PGSQL.5432 - which
> the forums suggested I run a purge and re-install which I already did once.
> They also suggested running *sudo apt-get install --reinstall
> postgresql-9.5* which did not create the .s.PGSQL.5432 socket, and when I
> try and run *./pg_ctl reload *or *./pg_ctl restart *from the
> /usr/lib/postgresql/9.5/bin location it tells me no database is specified.
> And when I try to specify the location that *sudo -u postgres psql -c
> "show data_directory;" *shows me on the alternate server which is
> /var/lib/postgresql/9.3/main with *./pg_ctl restart -D
> /var/lib/postgresql/9.5/main* it tells me it's not a database cluster
> directory - and without the -D it tells me that environment variable PGDATA
> is unset but so far I cannot find a command or config file that lets me set
> it that works as I'm checking the working server and not finding where it
> is set since postgresql.conf has the data_directory set and running
> pg_config also displays them on the test server and running server. When I
> try *./postgres -D /var/lib/postgresql/9.5/main *it says it cannot find
> the postgresql.conf file which makes sense since it's in
> /etc/postgresql/9.5/main. So should I just purge it again and re-re-install
> postgres?
>
> postgres is running - *ps axf | grep postgres* returns
>  8098 pts/0    S+     0:00  |                       \_ grep postgres
>
> running *netstat -nltp | grep 5432 *and *netstat -nlp | grep 5432* as
> root return nothing, no errors. IPTables -L shows nothing helpful -- I
> added port 5432 to iptables.
>
> Chain INPUT (policy ACCEPT)
> target     prot opt source               destination
> ACCEPT     tcp  --  sage.eou.edu         anywhere             tcp
> dpt:postgresql
>
> Chain FORWARD (policy ACCEPT)
> target     prot opt source               destination
>
> Chain OUTPUT (policy ACCEPT)
> target     prot opt source               destination
>
>
> I even tried creating a softlink in case it was looking at the wrong
> location as suggested on a forum - no change. *ln -s /tmp/.s.PGSQL.5432
> /var/run/postgresql/.s.PGSQL.543* - except the issue is that there is no
> .s.PGSQL5432 in the /tmp/ folder either. Yes, I removed it when it did not
> resolve the issue.
>
> I've tried running *psql -U postgres -h localhost* to create the
> evergreen user without success.
>
> I changed the /etc/postgresql/9.5/main/postgresql.conf file to 
> *listen_addresses
> = '*' *and added the test server's IP under IPv6 local connections like
> the other servers have it in the /etc/postgresql/9.5/main/pg_hba.conf file.
> They also had the following set:
>
> # Database administrative login by Unix domain socket
> local   all             postgres                                trust
>
> # "local" is for Unix domain socket connections only
> local   all             all                                     trust
>
> I've tried it as both peer and trust without success.
>
> I've restarted the postgres service after those changes.
>
> When I go to /openils/bin/srfsh and ask for the ils version I get 3.1.1.
> Suggestions?
> -Jon
>

Reply via email to