Peter Taphouse wrote:
> Hi,
> 
> I'm currently testing an iscsi box based on the gigastorATX board.  When
> running a couple of basic bonnie benchmark over the target the write
> portion of the test runs fine up until the re-write starts, at which
> point everything slows down and no i/o happens for periods of up to a
> minute followed by burts of reads and writes.
> 
> Taking this back to the most basic thing I could think of I've decided
> to just run cat /dev/sdXXX > /dev/zero .  This can pause for well over a
> minute before any i/o appears to happen.
> 
> I'm running the version of 2.0-865 of the initiator, on a 64bit debian
> etch install, over intel gige with an 8000 byte mtu.  I've tried
> identical tests with an open-e based target and have encountered no
> problems.  I've also tried the standard version of the initiator that
> comes packaged with etch, and that behaved the same as the latest version.
> 
> Has anyone seen anything similar before, or can shed any light on this?

Are you using exactly 2.0-865? If so could you try the userspace tools 
and kernel modules in:
http://www.open-iscsi.org/bits/open-iscsi-2.0-865.15.tar.gz

There are two write fixes in there. It sounds like you are hitting a 
problem where we counted some variable incorrectly and halt writes for 
no good reason.

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to