Thank you, that worked.
I get a disconnect when iscsid runs, but it re-connects and everything
continues fine.
Everything is up and running.

John.
p.s. Silly me, wrong code base :-p

On Dec 11, 6:57 pm, Mike Christie <[EMAIL PROTECTED]> wrote:
> mutsu wrote:
> > I'm running a vanilla 2.6.18 kernel with openvz patched in (stab039)
> > and using iscsi as root.
> > I have iscsistart in the initrd and it boots fine, but after a brief
> > period of time, it disconnects from the server. (under a minute.)
> > Using revision 866 from berlios
>
> Do not use that. It is old. Use what is on the open-iscsi page.
> git clone git://git.kernel.org/pub/scm/linux/kernel/git/mnc/open-iscsi.git
>
>
>
> > When I run iscsistart for root, I get the following error:
> > 1316:913:demo01:MgmtExec: 7-Dec-2007 18:25:24.160914:targetAttr.cc:
> > 933:INFO:7.2.15:iSCSI session to target '10.1.13.21:3260, iqn.
> > 2001-05.com.equallogic:0-8a0906-4c0233602-7fbfb1cde0a4759d-dl.ut1-eris-
> > base' from initiator '10.1.4.24:49498, iqn.1997-01.net.verio:ut1-eris'
> > was closed.
> >         iSCSI initiator connection failure.
> >         No response on connection for 6 seconds.
>
> That is expected in old versions. The nop handling was always done in
> the kernel in old vresions. In new versions (what will be in 2.6.25 and
> in the open-iscsi git tree I linked to above) we handle them in the kernel.
>
>
>
> > I've tried running iscsid and when I do, it disconnects the iscsi root
> > drive and tties to reconnect, but attempts to do so with CHAP turned
> > on. (It is not set on in the configuration on the client or equallogic
> > server)
>
> That is an old bug in the berilos code. Use the git code I pointed to
> and that should be fixed.
>
> For boot you should just use iscsisgtart to start the session in the
> initrd. When the system comes up, you should then start iscsid, because
> that daemon handles error handling. That should all work in the git
> tree. In the berilos tree it should all be broken :)
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to