Pasi Kärkkäinen escribió:
> On Wed, Jan 09, 2008 at 11:13:26AM -0500, Miguel Gonzalez Castaños wrote:
>   
>>     
>>> Well, this is your problem. Fix it first.
>>>
>>> If you can't get better throughput with FTP/HTTP/CIFS, how could you with
>>> iSCSI? 
>>>
>>> Sounds like you're running at 100 Mbit/sec.
>>>   
>>>       
>> I'm researching on this matter. I have tested from the machine where 
>> Virtual Server is running using hrping:
>>
>> hrping -l 4096 -t 10.0.6.41
>>
>> Statistics for 10.0.6.41:
>> [Aborting...]
>>     Packets: sent=70, rcvd=70, error=0, lost=0 (0% loss) in 34.500313 sec
>>     RTTs of replies in ms: min/avg/max: 0.304 / 0.331 / 0.426
>>
>> from your calculations that means around 13 MB/s
>>
>> Even at my home LAN where I have a very cheap gigabit switch and I use 
>> CAT 5e (so I'd meant to get around 200 Mb/s) and I'm getting with hrping 
>> around 15 MB/s
>>
>> Maybe We have something wrong with our switches (my boss says that all 
>> are gigabit) or with our cabling.
>>
>> Thanks!
>>
>>     
>
> OK.
>
> Remember that 4k I mentioned was just an example, because that's the often
> used block size by many filesystems.. 
>
> If you do (or if your application does) larger requests, you can easily get
> much more throughput.. for example 128k requests will give you much more
> throughput..
>
> And then you can have many outstanding io's active at the same time..
> depending on the used queue depth, io elevator etc..
>
> iometer (on windows) let's you choose number of outstanding io's..
>
> But yeah, first fix the throughput to be good with FTP/HTTP/CIFS and then
> start playing with iSCSI.
>   
I've connected a cross-over cable and created an ad-hoc network. hrping 
is not being very meaningful:

hrping -L 4096 -t 10.0.7.41

RTTs of replies in ms: min/avg/max: 0.228 / 0.266 / 1.121

However, I have installed bing. The performance it gives is around 500 
Mbps in the cross-over network.

The problem here is both machines are running Windows, the open-iscsi 
client would be running in a Virtual Server machine running Debian.

Running bing from the host Virtual Server against the debian virtual 
machine reduces the performance to around 60 Mbps. The tulip driver in 
Debian for Virtual Server configures a Fast Ethernet network card. 
Although Microsoft claims that the real performance is limited by the 
physical network, apparently is not the case for Debian virtual machines.

About the MTU, I get 1500 in the client part, in the initiator. Do I 
need a bigger MTU? Is it possible to change that?

Thanks,

Miguel

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to