Hello again,

Sorry for not getting back earlier - I had some high-prio personal things to
take care of.

Last week OpenSuse released open-iscsi 2.0.866-15.2 via their update tool,
but this did not solve the problem.

I have tried to compile the latest (2.0.866-rc1) iscsi drivers, but I run
into difficulties.
# make KSRC=/usr/src/linux KBUILD_OUTPUT=/usr/src/linux-obj/i586/default
quits with the following errors:
echo "Patching source code for linux-2.6.20-21 ..."
Patching source code for linux-2.6.20-21 ...
if [ -e cur_patched ]; then \
                make -C . clean; \
        fi
patch -p1 < 2.6.20-21_compat.patch
patching file iscsi_2.6.22_compat.h
patching file iscsi_tcp.c
Hunk #2 succeeded at 1947 (offset 3 lines).
patching file iscsi_tcp.h
patching file libiscsi.h
patching file scsi_transport_iscsi.c
Hunk #2 succeeded at 1270 (offset 4 lines).
cp 2.6.20-21_compat.patch has_20to21_patch ln -s has_20to21_patch
cur_patched make -C /usr/src/linux M=`pwd`
KBUILD_OUTPUT=/usr/src/linux-obj/i586/default  V=0 modules
make[2]: Entering directory `/usr/src/linux-2.6.22.17-0.1'
  CC [M]  /root/tmp/open-iscsi-2.0-868-rc1/kernel/scsi_transport_iscsi.o
In file included
from /root/tmp/open-iscsi-2.0-868-rc1/kernel/scsi_transport_iscsi.c:32:
/root/tmp/open-iscsi-2.0-868-rc1/kernel/iscsi_2.6.22_compat.h:75: error:
redefinition of 'scsi_set_resid'
/usr/src/linux-2.6.22.17-0.1/include/scsi/scsi_cmnd.h:148: error:
previous definition of 'scsi_set_resid' was here
/root/tmp/open-iscsi-2.0-868-rc1/kernel/iscsi_2.6.22_compat.h:80: error:
redefinition of 'scsi_get_resid'
/usr/src/linux-2.6.22.17-0.1/include/scsi/scsi_cmnd.h:153: error:
previous definition of 'scsi_get_resid' was here
make[4]: ***
[/root/tmp/open-iscsi-2.0-868-rc1/kernel/scsi_transport_iscsi.o] Error 1
make[3]: *** [_module_/root/tmp/open-iscsi-2.0-868-rc1/kernel] Error 2
make[2]: *** [modules] Error 2
make[2]: Leaving directory `/usr/src/linux-2.6.22.17-0.1'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/root/tmp/open-iscsi-2.0-868-rc1/kernel'
make: *** [all] Error 2

I am new to compiling kernel modules. Should I first uninstall the old
version of open-iscsi which shippes with OpenSuse?
The README file said something about configuring the kernel with
CONFIG_CRYPTO and CONFIG_CRYPTO_CRC32C. How do I do that?

Mvh
Lauri Lubi
Tel +46 730 39 31 00
 

-----Ursprungligt meddelande-----
Från: open-iscsi@googlegroups.com [mailto:[EMAIL PROTECTED] För
Mike Christie
Skickat: den 28 februari 2008 08:29
Till: open-iscsi@googlegroups.com
Ämne: Re: opensuse 10.3, vmware, open-iscsi keeps crashing


Lauri Lubi wrote:
> Hello,
> 
>  
> 
> Does any one else have the same problem or solution for it?
> 
> A newly installed opensuse 10.3, vmware, open-iscsi (2.0.866-15)
combination
> keeps crashing. It might have something to do with the network drivers as
I
> see "hw csum failure" in the messages log file.
> 
> Sometimes the open-iscsi hangs leaving iscsi-mount inaccessible, sometimes
> the whole machine freezes. The problem occurs when doing extensive
> read-write, it is possible to read-write non-extensively before the crash.
> 
>  
> 
> Kernel: Linux version 2.6.22.17-0.1-default

It looks like you are hitting a race in the error handler and xmit code. 
You should use the iscsi modules in the open-iscsi tarball, or update to 
  a kernel based on 2.6.23 which has this fixed.



No virus found in this incoming message.
Checked by AVG Free Edition. 
Version: 7.5.516 / Virus Database: 269.21.1/1302 - Release Date: 2008-02-27
16:34
 


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to