v i n c e wrote:
> Hello all,
> 
> I am trying to setup an iscsi root disk; googled instructions that
> suggests to make changes to init in the initrd;  before doing so I
> wanted to test the "iscsistart" CLI.  I am able to connect to my
> target when I start the iscsi daemon via the:  service iscsi start.
> However, I am unable to start using the iscsistart CLI:
> 
> iscsistart -i iqn.1994-05.com.redhat:a950ce57a2bb -t iqn.
> 2008-04.com.mycompany.lab:storage.rootdisk -g 1 -a 192.168.17.3 -d 8
> iscsistart: Could not open /sys/module/scsi_transport_iscsi/version.
> 

When you run iscsistart you cannot have iscsid running and you must load 
the modules by hand. So you have to do the modprobe iscsi_tcp that the 
init script would normally do for you.


> iscsistart: Missing or Invalid version from /sys/module/
> scsi_transport_iscsi/version. Make sure a up to date
> scsi_transport_iscsi module is loaded and a up todate version of
> iscsid is running. Exiting...

this indicates that the iscsi modules might not be loaded or you might 
have compiled them into the kernel. We do not support the latter (some 
people sent patches to fix this upstream but I am not sure of the status).

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to