An Oneironaut schrieb:
> Hey all,
>       So I'm having some problems using umount an my iSCSI device.  I
> have my timeout period set to a really long time and the no-op timers
> have been switched off.  If my system loses its connection to the
> iSCSI and I try to umount the device the command hangs.  I've tried
> umount with the 'l' flag and the 'f' flag but neither have worked.
> And when I do this I am not able to kill the process even with kill
> -9.  I've tried killing all the processes associate with the mount
> before umounting it.  But nothing seems to work.
>     Even when I try to reboot my system will hang requiring a hard
> reset.  I've tried 'reboot -f' and 'reboot -n' but neither work.  Has
> anyone run into this before or have any ideas how I can achieve either
> a umount or a successful reboot?

Well, if you have a really long timeout and your connection is lost, 
umount and everything else will - not surprisingly - timeout with the 
period you specified.

Your solutions are:

- restore the connection
- if possible, try to decrease the timeout just before loosing the 
- if the connection is lost already, you may also try to decrease the 
timeout, but I'm not sure it'll work,
- don't shut your network interfaces down when rebooting or halting the 
system (distro-specific; for Debian, look into /etc/init.d/halt and 
NETDOWN / $netdown; others may use $HALTARGS variable in 
/etc/init.d/halt etc.).

An example for setting the timeout to 120 seconds:

iscsiadm -m node -T -o update -n 
node.session.timeo.replacement_timeout -v 120

Tomasz Chmielewski

You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at

Reply via email to