Albert Pauw wrote:
> Hi Mike,
> 
> hope you can replicate this.
> 
> I started up stgt to function as the target, but with no target
> defined.
> I have a script with can add a target later, using tgtadm, the target
> created by this script is already in the open-iscsi database, so I
> don't have to do a discovery anymore.
> 
> I tried to login with open-iscsi into the "target" (as I had forgotton
> to
> run the script to actually create the target in stgt). Obviously, it
> won't
> work, I break off the login with CTRL-C.
> 

You do CTRL-C to iscsiadm right?

> Now I run my target script to create the target, and try to login
> again
> with open-iscsi, now I get the following error:
> 
> [EMAIL PROTECTED] usr]# iscsiadm -m node -T iqn.2008-07:virtual-
> disk:orange.pauw.homeunix.net -l
> Logging in to [iface: default, target: iqn.2008-07:virtual-
> disk:orange.pauw.homeunix.net, portal: 127.0.0.1,3260]
> iscsiadm: Could not login to [iface: default, target: iqn.
> 2008-07:virtual-disk:orange.pauw.homeunix.net, portal:
> 127.0.0.1,3260]:
> iscsiadm: initiator reported error (15 - already exists)
> 
> I have to stop and restart the initiator get it to log in again.
> 

iscsiadm does not fully cleanup from a CTRL-C correctly. It will break 
out of whatever it is doing, but if it was in the middle of trying to 
login to a target that was not there it would not clean that login 
attempt up as a result of the CTRL-C. So if you run iscsiadm again, and 
iscsid is still trying to login from the attempt that got CTRL-C'd you 
get the error above, because iscsid is still working on the first 
request. What will eventually happen is the first attempt will fail or 
succeed (there is actually a bug in older tools where we might retry 
forever though).

So it is a known bug. I will get to it soonish. It is low on the list 
because it only happens when we do a CTRL-C.

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to