Mathias Gug wrote:
> Hi Lars,
> 
> On Wed, Dec 10, 2008 at 02:05:37PM +0100, Lars Schimmer wrote:
>> I upgraded my system to a recent 2.6.26 kernel from debian and the
>> open-iSCSO package 2.0.870~rc3-0.3 from debian.
>>
>> But it keeps failing to start iSCSI, syslog tells me:
>> Dec 10 13:58:48 phobos iscsid: Missing or Invalid version from
>> /sys/module/scsi_transport_iscsi/version. Make sure a up to date
>> scsi_transport_iscsi module is loaded and a up todate version of iscsid
>> is running. Exiting...
>>
>> Problem of my system or general, does somebody know?
> 
> While working on updating the open-iscsi package for Ubuntu, we've found
> out that the Debian package 2.0.870~rc3 is mostly 2.0.869. This may be
> the cause of your problem.
> 
> See Debian bug 507496 [1] and Ubuntu bug 289470 [2] for more
> information.
> 
> [1]: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507496
> [2]: https://bugs.launchpad.net/ubuntu/+source/open-iscsi/+bug/289470
> 

This bug
https://bugs.launchpad.net/ubuntu/+source/open-iscsi/+bug/289470
is caused because the upstream kernel changed the sysfs layout and older 
tools were not preapred for it.

http://www.open-iscsi.org/bits/open-iscsi-2.0-870.1.tar.gz fixes it.

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to