Boaz Harrosh wrote:
> 
> A couple of prints at lib/iscsi_tcp had the %Z missing from the
> kprint format string. Just to show that debug_prints are not enabled
> much.
> 
> Signed-off-by: Boaz Harrosh <bharr...@panasas.com>
> ---
>  drivers/scsi/iscsi_tcp.c    |    2 +-
>  drivers/scsi/libiscsi_tcp.c |    2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/scsi/iscsi_tcp.c b/drivers/scsi/iscsi_tcp.c
> index 23808df..a566aa9 100644
> --- a/drivers/scsi/iscsi_tcp.c
> +++ b/drivers/scsi/iscsi_tcp.c
> @@ -415,7 +415,7 @@ iscsi_sw_tcp_send_linear_data_prep(struct iscsi_conn 
> *conn, void *data,
>       struct hash_desc *tx_hash = NULL;
>       unsigned int hdr_spec_len;
>  
> -     debug_tcp("%s(%p, datalen=%d%s)\n", __func__, tcp_conn, len,
> +     debug_tcp("%s(%p, datalen=%Zd%s)\n", __func__, tcp_conn, len,
>                 conn->datadgst_en? ", digest enabled" : "");
>  


I got these fixed when I did the modparam debug patch.

I used a lower case z (%zd) though. I thought I saw that in a review 
comment from Andrew Morton or in a kernel janitor patch, so I thought 
that was the preferred way to do it in kernel code, but was not 100% 
sure. Let me know if I goofed and I will fix it.

Thanks.

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to 
open-iscsi+unsubscr...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to