Mike,
Response in line....

On Apr 20, 5:14 pm, Mike Christie <micha...@cs.wisc.edu> wrote:
> Joer wrote:
> > A few more comments on this failure:
> > This may be a problem with how the check response is being processed
> > by the iSCSI stack...possibly due to data digest.
>
> > The Inquiry command goes out, the response is received with data
> > digest, and appears to be accepted.  A Test Unit Ready command then
> > goes out, response received, and 500 ms later the initiator attempts
> > to open a new connection/login.   The target then resets the original
> > TCP connection.  This is repeated several times
>
> Is this easy to replicated? Does it happen every time?
Yes, but only with data digest.  The cases that fail are data digest
only, header + data digest.
>
> Were you using the initiator that comes with RHEL 5.2 or 2.0-869.2 from
> open-iscsi.org?
I am using the initiator from open-iscsi.org.
>
>
>
> > Is it possible that the check response with data digest is not being
> > handled correctly?
>
> > The /var/log/message contains a series of the following messages:
>
> > connection2:0:0 detected conn error (1011)
>
> Do you see any 1015 errors? 1015 is for data digest errors. 1011 is
> generic connection problems or cases where we dropped it for some
> generic reason.
Solid 1011 errors.  I have gone over the response trace looking for
PDU errors of any kind and could not find any.
>
> Is there anything else in the log? Something about a ping or nop timing out?
Not that I could see.
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to 
open-iscsi+unsubscr...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to