On 09/04/2009 07:58 AM, Yao Wei wrote:
> Dear sir:
>
> I have tested iscsi protocols on two machines using open-iscsi and
> iscsi-target. On IBM X3550 machine which has two NICs (SUSE Linux Enterprise
> 10.1) I simulate iscsi initiator , and on Dell Optiplex 755 machine (Fedora
> 8 ) for iscsi target . The network environment is 1GbE.
>
> Unfortunately, when I discovery the target, and used hdparm to test the read
> speed, I found the speed could only obtain 10MB/s.
>
> Later, I let the IBM X3550 to be the target, and let Dell 755 to be
> initiator, the speed could obtain above 80MB/s.
>
> I can not know the reason. Looking forword to your replies.
>

What are you using for storage on the iscsi-target? For perf testing you 
probably want to use a null device (it does not actually do any disk IO 
so it is very fast):

Target iqn.2001-04.com.redhat:perftest
        Lun 0 Type=fileio,Type=nullio,Sectors=10485760


How are you running hdparm? Have you tried other tools? What IO sizes 
are you using and how many IOs are you sending at a time?

Have you tried different IO schedulers (echo noop > 
/sys/block/sdXYZ/queue/scheduler)?

What IO throughput do you get when just running a nettool like netperf?

If you run ethtool can you confirm the net layer did negotiate for 1 GbE 
and there was not a messup where we ended up with 10 Mb?

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to 
open-iscsi+unsubscr...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to