On Wed, Oct 28, 2009 at 9:22 AM, Lee Amy <openlinuxsou...@gmail.com> wrote:
> On Wed, Oct 28, 2009 at 6:13 AM, Mike Christie <micha...@cs.wisc.edu> wrote:
>>
>> Eric Lee wrote:
>>> Hi,
>>>
>>> I encountered such errors when login the target. The target was
>>> implemented by using iET.
>>>
>>> #iscsiadm -m node -l
>>> Logging in to [iface: default, target:
>>> iqn.2009-10.master:storage.disk1.sys1.xyz, portal:
>>> 192.168.140.136,3260]
>>> iscsiadm: Could not login to [iface: default, target:
>>> iqn.2009-10.master:storage.disk1.sys1.xyz, portal:
>>> 192.168.140.136,3260]:
>>> iscsiadm: initiator reported error (12 - iSCSI driver not found.
>>> Please make sure it is loaded, and retry the operation)
>>>
>>> Then I notice that the system does not load iscsi_tcp module. So I'm
>>> trying to load this module.
>>> #modprobe iscsi_tcp
>>> iscsi_tcp: Unknown symbol iscsi_tcp_segment_done
>>> iscsi_tcp: Unknown symbol iscsi_segment_seek_sg
>>> iscsi_tcp: Unknown symbol iscsi_tcp_segment_unmap
>>> iscsi_tcp: Unknown symbol iscsi_tcp_hdr_recv_prep
>>> iscsi_tcp: Unknown symbol iscsi_tcp_cleanup_task
>>> iscsi_tcp: Unknown symbol iscsi_tcp_conn_setup
>>> iscsi_tcp: Unknown symbol iscsi_tcp_r2tpool_alloc
>>> iscsi_tcp: Unknown symbol iscsi_tcp_r2tpool_free
>>> iscsi_tcp: Unknown symbol iscsi_tcp_task_xmit
>>> iscsi_tcp: Unknown symbol iscsi_tcp_recv_skb
>>> iscsi_tcp: Unknown symbol iscsi_segment_init_linear
>>> iscsi_tcp: Unknown symbol iscsi_tcp_conn_get_stats
>>> iscsi_tcp: Unknown symbol iscsi_tcp_task_init
>>> iscsi_tcp: Unknown symbol iscsi_tcp_dgst_header
>>> iscsi_tcp: Unknown symbol iscsi_tcp_conn_teardown
>>> FATAL: Error inserting iscsi_tcp
>>> (/lib/modules/2.6.18-128.el5/kernel/drivers/scsi/iscsi_tcp.ko):
>>> Unknown symbol in module, or unknown parameter (see dmesg)
>>>
>>> So obviously I cannot load the module properly. So I don't know how to
>>> fix that.
>>>
>>> My OS is Cent OS 5.3 32bits. The kernel source codes are provided by
>>> distributor.
>>>
>>> Could anyone tell me how to fix that problem?
>>>
>>
>> You are missing libiscsi_tcp. Are you running the kernel modules from
>> the open-iscsi.org tarball or from a kernel you built?
>>
>> >>
>>
> Mike,
>
> I downloaded the tarball from open-iscsi.org then build from source
> and install. It runs well when build.
>
> Thanks.
>
> Eric
>

Hi,

It builds well but when I want to load the module it always shows the
error messages I pasted.

Could you tell me how to deal with it?

Thanks.

Eric

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to 
open-iscsi+unsubscr...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to