On 06/21/2010 01:27 AM, EK Shen wrote:
Hi!
I am porting open-iscsi to Marvell Kirkwood (6281) board and
encountered "invalid session" problem. The Linux kernel version is
2.6.22.18. I have tried open-iscsi 2.0-871, 870, 869 and got the same
error.
I tried the same code in my Linux desktop running Fedora 11. It is
working fine.
Is there anyone who met similar problem before?

I traced the code and found that the session is created successfully
but the connection failed to be created because the session lookup
fails.
It should be that "sid 1" is created but "sid 2" is provided for
session lookup.

What arch is this? Is it 64 bit? Are you doing 64 bit kernels and 32bit userspace? There is a bug where if using 32bit userspace but 64 bit kernels then data transmitted between the kernel and userspace gets messed up and you end up with lots of weird bugs like this?

Are you using the tools and kernel from the open-iscsi.org target ball or do you use the tools from open-iscsi.org then the kernel modules from 2.6.22?



I suspect some data transmission problem occurs between user space and
kernel space.
This problem is very wierd for me.
Could anyone give me some feedback or share experience?
Thanks a lot!

========================================================
# iscsid -d 8 -f&
# iscsiadm -m discovery --type sendtargets --portal 192.168.107.150 -P
1
...
Target: iqn.2001-04.com.example:storage.disk2.sys1.xyz
         Portal: 192.168.107.150:3260,1
                 Iface Name: default
         Portal: 192.168.122.1:3260,1
                 Iface Name: default
# iscsiadm -d 8 -m node -l
iscsiadm: Max file limits 1024 1024
...
iscsiadm: to [iqn.2001-04.com.example:storage.disk2.sys1.xyz,
192.168.122.1,3260][d]
Logging in to [iface: default, target: iqn.
2001-04.com.example:storage.disk2.sys1.]
iscsid: poll result 1
...
iscsid: Allocted session 0x3bbf0
iscsid: no authentication configured...
iscsid: resolved 192.168.107.150 to 192.168.107.150
...
iscsid: connecting to 192.168.107.150:3260
iscsid: sched conn context 0x43048 evescsi2 : iSCSI Initiator over TCP/
IP
nt 2, tmo 0
iscsid: thread 0x43048 schedule: delay 0 state 3
iiscsi: invalid session 2.
scsid: Setting login timer 0x40fb0 timeout 15
iscsid: thread 0x40fb0 schedule: delay 60 state 3
Logging in to [iface: default, target: iqn.
2001-04.com.example:storage.disk2.sys1.]
iscsid: exec thread 00043048 callback
iscsid: put conn context 0x43048
iscsid: connected local port 59347 to 192.168.107.150:3260
iscsid: in kcreate_session
iscsid: in __kipc_call
iscsid: in kwritev
iscsid: in nlpayload_read
iscsid: expecting event 11, got 106, handling...
iscsid: in ctldev_handle
iscsid: in nl_read
iscsid: ctldev_handle got event type 106
....
iscsid: in nlpayload_read
iscsid: in nlpayload_read
iscsid: Could not set session2 priority. READ/WRITE throughout and
latency could b.

iscsid: created new iSCSI session sid 2 host no 0
iscsid: in kcreate_conn
iscsid: in __kipc_call
iscsid: in kwritev
iscsid: in nlpayload_read
iscsid: expecting event 13, got 103, handling...
iscsid: in nlpayload_read
iscsid: Received iferror -22
iscsid: returned -22
iscsid: can't create connection (0)
iscsid: disconnect conn
...



--
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-is...@googlegroups.com.
To unsubscribe from this group, send email to 
open-iscsi+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/open-iscsi?hl=en.

Reply via email to