Package: openerp-server
Version: 5.0.6-3
Severity: important

*** Please type your report below this line ***


Hello,

if used together with postgresql-8.4, openerp-server uses an inappropriate SQL
statement to create the initial database. This results in no database being
created, thus the inability to make any kind of use of the package.

The following patch fixes this:

--- web_services.py.orig        2009-09-22 15:18:06.000000000 +0200
+++ web_services.py     2010-02-02 15:46:05.000000000 +0100
@@ -75,7 +75,7 @@
         cr = db.serialized_cursor()
         try:
             cr.autocommit(True) # XXX inhibit the effect of a serialized 
cursor. is it what we want ?
-            cr.execute('CREATE DATABASE "%s" ENCODING \'unicode\'' % db_name)
+            cr.execute('CREATE DATABASE "%s" ENCODING \'unicode\' TEMPLATE 
template0' % db_name)
         finally:
             cr.close()
             sql_db.close_db('template1')


Kind regards,
--Toni++


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'proposed-updates'), (500, 'stable'), 
(250, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-trunk-686-bigmem (SMP w/4 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages openerp-server depends on:
ii  adduser                      3.112       add and remove users and groups
ii  debconf [debconf-2.0]        1.5.28      Debian configuration management sy
ii  python                       2.5.4-9     An interactive high-level object-o
ii  python-libxslt1              1.1.26-1+b1 Python bindings for libxslt1
ii  python-lxml                  2.2.4-1+b1  pythonic binding for the libxml2 a
ii  python-psycopg2              2.0.13-2+b1 Python module for PostgreSQL
ii  python-pychart               1.39-7      Python library for creating high q
ii  python-pydot                 1.0.2-1     Python interface to Graphviz's dot
ii  python-reportlab             2.3-1       ReportLab library to create PDF do
ii  python-tz                    2009u-1     Python version of the Olson timezo

Versions of packages openerp-server recommends:
ii  ghostscript                8.70~dfsg-2.1 The GPL Ghostscript PostScript/PDF
ii  graphviz                   2.20.2-7      rich set of graph drawing tools
ii  postgresql                 8.4.2-2       object-relational SQL database (su
ii  postgresql-client-8.4 [pos 8.4.2-2       front-end programs for PostgreSQL 
ii  python-imaging             1.1.7-1+b1    Python Imaging Library
ii  python-matplotlib          0.99.1.2-2+b1 Python based plotting system in a 
ii  python-openssl             0.9-1+b1      Python wrapper around the OpenSSL 
ii  python-pyparsing           1.5.2-1       Python parsing module

Versions of packages openerp-server suggests:
ii  openerp-client                5.0.6-2    Enterprise Resource Management (cl

-- debconf information excluded

-- debsums errors found:
debsums: changed file /usr/lib/openerp-server/service/web_services.py (from 
openerp-server package)


_______________________________________________
open-object mailing list
open-object@lists.debian-maintainers.org
http://lists.debian-maintainers.org/listinfo/open-object

Reply via email to