The following commit has been merged in the master branch:
commit 0dbe0fba4f4249be11524f8e2d3a1e115591cd18
Author: Andrew Deason <[email protected]>
Date: Tue Apr 6 17:07:33 2010 -0500
Use afsd code in libuafs
Share the same CM code for the kernel client as in libuafs, so we
don't duplicate code for initializing the cache and other things. In
order to do this:
- Remove some libuafs global variables that share name and
functionality with those in afsd, and declare some static
- Remove uafs_Init(), and move the ukernel-specific code in it to
osi_Init(); replace with uafs_Setup(), uafs_ParseArgs(), and
uafs_Run(), which just call into afsd functions
- Remove libuafs' cache initialization code (CreateCacheFile,
SweepAFSCache, etc); instead just use afsd's
- Add uafs_mount(), to perform the 'mount'ing step that takes place
in the normal kernel CM
- Add afsd_uafs.c for the glue between afsd and libuafs
Note that this now requires libcmd for libuafs.
Change-Id: I62306a18ad255680031494caf1720b29e22856d2
Reviewed-on: http://gerrit.openafs.org/1724
Reviewed-by: Derrick Brashear <[email protected]>
Tested-by: Derrick Brashear <[email protected]>
Makefile.in | 2 +-
src/afs/UKERNEL/afs_usrops.c | 948 ++++++----------------------------------
src/afs/UKERNEL/afs_usrops.h | 26 +-
src/afs/UKERNEL/afsd_uafs.c | 73 +++
src/afs/UKERNEL/sysincludes.h | 15 -
src/afsd/afsd.c | 91 +++--
src/config/stds.h | 2 +-
src/libuafs/Makefile.common.in | 23 +-
src/libuafs/linktest.c | 23 +-
9 files changed, 292 insertions(+), 911 deletions(-)
--
OpenAFS Master Repository
_______________________________________________
OpenAFS-cvs mailing list
[email protected]
https://lists.openafs.org/mailman/listinfo/openafs-cvs