Dear Harald,
just wanna give report what I tests.
I test calls and when I picked up always hang up and paging fail for the
first call.

sometimes osmo-mgw having this fail:
0180202124344842 DLMGCP <0011> mgcp_msg.c:262 Addressing virtual trunk
without prefix (deprecated), please use rtpbridge/: '1@mgw'
20180202124344842 DLMGCP <0011> mgcp_protocol.c:727 MDCX: modifying
existing connection ...
20180202124344842 DLMGCP <0011> mgcp_protocol.c:779 MDCX: endpoint:0x1
insufficient parameters, missing ci (connectionIdentifier)
20180202124344842 DLMGCP <0011> mgcp_protocol.c:154 Generated response:
code=515
20180202124344842 DLMGCP <0011> mgcp_msg.c:64 Generated response: line #00:
515 119 FAIL

but I think my configuration for osmo-mgw -c ~/osmo/osmo-mgw-for-msc.cfg
has wrong cause I found this:
20180202115457644 DRTP <0000> mgcp_network.c:833 endpoint:0x1 data from
wrong address: 127.0.0.1, expected: 0.0.0.0
20180202115457644 DRTP <0000> mgcp_network.c:837 endpoint:0x1 packet tossed
20180202115457663 DRTP <0000> mgcp_network.c:1070 endpoint:0x1 source
conn:(1/rtp, id:0x9BD31876C21AF4272B337F95C5

I will try to look what may cause the connection hang up for my problem.

Thanks,
DUO




On Fri, Feb 2, 2018 at 11:58 AM, Sandi Suhendro <djk...@gmail.com> wrote:

> Dear Harald,
> sorry for the authentication matter,
> I got the solution now, I need to set encryption to a5 0 on the config.
>
> Thanks for lightneing up before.
>
> btw,
> I try to make call but cannot hear the voices. will try this again and
> again.
>
> Thanks,
> DUO
>
> On Fri, Feb 2, 2018 at 11:30 AM, Sandi Suhendro <djk...@gmail.com> wrote:
>
>> Dear Harald,
>> thank you for explanation, I really appreciate it.
>>
>> So, osmo-hlr now need authentication for connect to the network? so we
>> cannot attach IMSI without the ki?
>>
>> if Im not wrong I need to set disable it on the configuration?
>>  location updating reject cause 13
>>  encryption a5 1
>>  authentication optional
>>
>> on this authentication line need to change? I try do change to
>> authentication disable, but not work. I believe I have wrong understanding
>> here.
>>
>> Im using for 2g network. as far I know only for 3g network you need ki
>> right?
>>
>> Hope some feedback. Thank you.
>>
>> regards,
>> DUO
>>
>> On Fri, Feb 2, 2018 at 7:13 AM, Harald Welte <lafo...@gnumonks.org>
>> wrote:
>>
>>> Hi!
>>>
>>> On Thu, Feb 01, 2018 at 07:14:41PM +0000, Sandi Suhendro wrote:
>>> > 20180201190135844 DAUC <0003> hlr.c:79 510106127044410: IMSI known,
>>> but has
>>> > no auth data; Returning slightly inaccurate cause 'IMSI Unknown' via
>>> GSUP
>>>
>>> the error is quite clear: You have only an IMSI in your HLR, but no
>>> authentication
>>> tokens (key material) for cryptographic authentication.
>>>
>>> If at the same time you have configured your network to perform
>>> authentication (i.e.
>>> not explicitly disabled it), then this will of course result in an error.
>>>
>>> Either you enter key data in the HLR for your SIM cards, or you disable
>>> authentication.
>>>
>>> > Does the new osmo-bsc on master cannot use? or maybe I need to
>>> investigate
>>> > more?
>>>
>>> The BSC has nothing to do with it.  Your error is in OsmoMSC or OsmoHLR
>>> configuration.
>>>
>>> --
>>> - Harald Welte <lafo...@gnumonks.org>
>>> http://laforge.gnumonks.org/
>>> ============================================================
>>> ================
>>> "Privacy in residential applications is a desirable marketing option."
>>>                                                   (ETSI EN 300 175-7 Ch.
>>> A6)
>>>
>>
>>
>>
>> --
>> Best Regards,
>> DUO
>>
>>
>
>
> --
> Best Regards,
> DUO
>
>


-- 
Best Regards,
DUO

Reply via email to