Hi List- Many thanks to Oliver Welter for helping me resolve my problem with SSLOptions +StdEnvVars that was causing my "too short symmetric keylength" error.
Now that I have that solved, I've encountered another problem in trying to follow the guidelines in the OpenCA cookbook from Kevin Mitcham. I do get pages when visiting all of the following: https://myhost.wherever.edu/ra https://myhost.wherever.edu/ra-node https://myhost.wherever.edu/pub https://myhost.wherever.edu/ca https://myhost.wherever.edu/ca-node What I get is as follows: https://myhost.wherever.edu/ra A purple login screen https://myhost.wherever.edu/ra-node A white login screen https://myhost.wherever.edu/pub A series of tabs labeled: General (Logout) CA Infos (Policy Get CA certificate Certificate Revocation Lists) User (Request a Certificate Get Requested Certificate Test Certificate Revoke Certificate) Certificates (Valid Expired Suspended Revoked Search) Requests (Certificate Requests Certificate Revocation Requests) Language (English German Spanish French Italian Japanese Polish) https://myhost.wherever.edu/ca A purple login screen https://myhost.wherever.edu/ca-node A white login screen In the cookbook, Kevin Mitcham says: connect to the ca: http://myhost.wherever.edu/openca Series of tabs should be visible. Select General->Initialization Phase I Initialize the Certification Authority Initialize Database initialize-> intialize DB .(reports sucess, but a slurry of error messages about table not found may appear on the console) Based upon the changes he recommends for httpd.conf, I assume he means to connect to http://myhost.wherever.edu/ca because that's what he makes an Alias for. With what username/password credentials should I login? The ones that I set up in my config.xml files? I assumed that these were the username/password of the mysql openca database administrator that I created when creating the databases themselves, but these aren't working. When I try it I get a login failed message. Must I permit access to port 3306 over the network? I can connect to the mysql server using the mysql command-line client program running on the server machine when using these credentials, but cannot do so through the web interface of OpenCA. The only place I see a series of tabs is at /pub and while there is a General tab, there is no Initialization item in it. Am I missing something? Any suggestions? I checked the list archives but didn't see anything that helped me out. Someone reported a problem with the cookie directory being created, but I'm not seeing the same symptoms he was. The exact error message is: Error Login failed. General Error. 6273120. Thanks again. -Kevin ------------------------------------------------------- SF.Net email is sponsored by Shop4tech.com-Lowest price on Blank Media 100pk Sonic DVD-R 4x for only $29 -100pk Sonic DVD+R for only $33 Save 50% off Retail on Ink & Toner - Free Shipping and Free Gift. http://www.shop4tech.com/z/Inkjet_Cartridges/9_108_r285 _______________________________________________ Openca-Users mailing list [EMAIL PROTECTED] https://lists.sourceforge.net/lists/listinfo/openca-users
