From: Gan Yau Wai <yau.wai....@intel.com>

The package_qa_check_rdepends() in insane.bbclass has
incorrectly replace its localdata OVERRIDES value with
the package name. Fixing it by appending the package name
to the existing OVERRIDES value. This resolves RDEPENDS QA
error when setting PACKAGECONFIG using a pn- override at
local.conf.

Cherry picked from master 60d28dd72daee235150ab6605cbf953f1ea691df
and modified to work with older bitbake where 2nd parameter in
localdata.getVar was mandatory.

[YOCTO #11374]

Signed-off-by: Gan Yau Wai <yau.wai....@intel.com>
Signed-off-by: Ross Burton <ross.bur...@intel.com>
Signed-off-by: Martin Jansa <martin.ja...@gmail.com>
---
 meta/classes/insane.bbclass | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index e541c72c2d..7bbe8b63a2 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -833,7 +833,7 @@ def package_qa_check_rdepends(pkg, pkgdest, skip, taskdeps, 
packages, d):
 
     if not "-dbg" in pkg and not "packagegroup-" in pkg and not "-image" in 
pkg:
         localdata = bb.data.createCopy(d)
-        localdata.setVar('OVERRIDES', pkg)
+        localdata.setVar('OVERRIDES', localdata.getVar('OVERRIDES', True) + 
':' + pkg)
         bb.data.update_data(localdata)
 
         # Now check the RDEPENDS
-- 
2.14.0

-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Reply via email to