Thanks for reworking this, it does look a lot better and should stop
some of the bbclass proliferation we're seeing.

I assume all the code was functionally unchanged in the move?

On Sun, 2018-11-18 at 13:19 -0600, Joshua Watt wrote:
>  python () {
> -    if oe.types.boolean(d.getVar("TESTIMAGE_AUTO") or "False"):
> -        bb.build.addtask("testsdk", None, "do_populate_sdk", d)
> -        bb.build.addtask("testsdkext", None, "do_populate_sdk_ext", d)
> +    auto = oe.types.boolean(d.getVar("TESTIMAGE_AUTO") or "False")
> +    bb.build.addtask("testsdk", None, ("", "do_populate_sdk")[auto], d)
> +    bb.build.addtask("testsdkext", None, ("", "do_populate_sdk_ext")[auto], 
> d)
>  }

This doesn't look like an improvement to code readability? :)

Cheers,

Richard



-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Reply via email to