On Wed, Mar 25, 2020 at 3:15 PM Mark Hatle
<mark.ha...@kernel.crashing.org> wrote:
>
> Trying to build mesa-gl without X11 enabled, results in numerous errors
> about being incorrectly configured, such as:
>
>   ERROR: Problem encountered: building dri drivers require at least one 
> windowing system or classic osmesa
>
> After consulting with the author of this recipe, it was clear that it
> was only intended for the X11 use-case, so requring X11 should avoid the
> error message above.
>
> Signed-off-by: Mark Hatle <mark.ha...@kernel.crashing.org>

This is wrong. We ought to add osmesa as fallback and not hard-require X11

-- 
Otavio Salvador                             O.S. Systems
http://www.ossystems.com.br        http://code.ossystems.com.br
Mobile: +55 (53) 9 9981-7854          Mobile: +1 (347) 903-9750
-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.

View/Reply Online (#136708): 
https://lists.openembedded.org/g/openembedded-core/message/136708
Mute This Topic: https://lists.openembedded.org/mt/72547327/21656
Group Owner: openembedded-core+ow...@lists.openembedded.org
Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub  
[arch...@mail-archive.com]
-=-=-=-=-=-=-=-=-=-=-=-

Reply via email to