On 7/14/20 10:02 AM, Ross Burton wrote:
> From: Ross Burton <[email protected]>
> 
> The messages from the ELF 'arch' test are not obvious, clarify the
> messages and prune output paths.
> 
> Signed-off-by: Ross Burton <[email protected]>
> ---
>  meta/classes/insane.bbclass | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
> index 89a516882b..ee19ef673e 100644
> --- a/meta/classes/insane.bbclass
> +++ b/meta/classes/insane.bbclass
> @@ -364,14 +364,14 @@ def package_qa_check_arch(path,name,d, elf, messages):
>              target_os == "linux-gnu_ilp32" or re.match(r'mips64.*32', 
> d.getVar('DEFAULTTUNE')))
>      is_bpf = (oe.qa.elf_machine_to_string(elf.machine()) == "BPF")
>      if not ((machine == elf.machine()) or is_32 or is_bpf):
> -        package_qa_add_message(messages, "arch", "Architecture did not match 
> (%s, expected %s) on %s" % \
> -                 (oe.qa.elf_machine_to_string(elf.machine()), 
> oe.qa.elf_machine_to_string(machine), package_qa_clean_path(path,d)))
> +        package_qa_add_message(messages, "arch", "Architecture did not match 
> (%s, expected %s) in %s" % \

Should this be called CPU architecture as well.

> +                 (oe.qa.elf_machine_to_string(elf.machine()), 
> oe.qa.elf_machine_to_string(machine), package_qa_clean_path(path, d, name)))
>      elif not ((bits == elf.abiSize()) or is_32 or is_bpf):
> -        package_qa_add_message(messages, "arch", "Bit size did not match (%d 
> to %d) %s on %s" % \
> -                 (bits, elf.abiSize(), bpn, package_qa_clean_path(path,d)))
> +        package_qa_add_message(messages, "arch", "Bit size did not match 
> (%d, expected %d) in %s" % \

Bit size perhaps should be called Word size to use more familiar term
for this.

> +                 (elf.abiSize(), bits, package_qa_clean_path(path, d, name)))
>      elif not ((littleendian == elf.isLittleEndian()) or is_bpf):
> -        package_qa_add_message(messages, "arch", "Endiannes did not match 
> (%d to %d) on %s" % \
> -                 (littleendian, elf.isLittleEndian(), 
> package_qa_clean_path(path,d)))
> +        package_qa_add_message(messages, "arch", "Endiannes did not match 
> (%d, expected %d) in %s" % \

typo, it should be Endianness

> +                 (elf.isLittleEndian(), littleendian, 
> package_qa_clean_path(path,d, name)))
>  
>  QAPATHTEST[desktop] = "package_qa_check_desktop"
>  def package_qa_check_desktop(path, name, d, elf, messages):
> 
> 
> 
> 
-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.

View/Reply Online (#140625): 
https://lists.openembedded.org/g/openembedded-core/message/140625
Mute This Topic: https://lists.openembedded.org/mt/75503366/21656
Group Owner: [email protected]
Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub  
[[email protected]]
-=-=-=-=-=-=-=-=-=-=-=-

Reply via email to