Set premerge_result and postmerge_result directly by calling getResult(), instead of doing it in multiple stages with confusing variable names.
Signed-off-by: Trevor Gamblin <[email protected]> --- scripts/patchtest | 9 ++------- 1 file changed, 2 insertions(+), 7 deletions(-) diff --git a/scripts/patchtest b/scripts/patchtest index aef80a86bb..d2f6302743 100755 --- a/scripts/patchtest +++ b/scripts/patchtest @@ -141,13 +141,8 @@ def run(patch, logfile=None): # Get the result class and install the control-c handler unittest.installHandler() - # run pre-merge tests, meaning those methods with 'pretest' as prefix - premerge_resultklass = getResult(patch, False, logfile) - premerge_result = _runner(premerge_resultklass, 'pretest') - - # run post-merge tests, meaning those methods with 'test' as prefix - postmerge_resultklass = getResult(patch, True, logfile) - postmerge_result = _runner(postmerge_resultklass, 'test') + premerge_result = _runner(getResult(patch, False, logfile), 'pretest') + postmerge_result = _runner(getResult(patch, True, logfile), 'test') print_result_message(premerge_result, postmerge_result) return premerge_result or postmerge_result -- 2.54.0
-=-=-=-=-=-=-=-=-=-=-=- Links: You receive all messages sent to this group. View/Reply Online (#239106): https://lists.openembedded.org/g/openembedded-core/message/239106 Mute This Topic: https://lists.openembedded.org/mt/119873970/21656 Group Owner: [email protected] Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [[email protected]] -=-=-=-=-=-=-=-=-=-=-=-
