was perusing the tasks defined in oe-core, and ran across this snippet in insane.bbclass which confused me:
# Check for patch fuzz do_patch[postfuncs] += "do_qa_patch " # Check broken config.log files, for packages requiring Gettext which # don't have it in DEPENDS. #addtask qa_configure after do_configure before do_compile do_configure[postfuncs] += "do_qa_configure " # Check does S exist. do_unpack[postfuncs] += "do_qa_unpack" i typically expect any functions whose names start with "do_" to represent tasks that should have an associated "addtask" directive, so i wasn't sure what to make of: do_patch[postfuncs] += "do_qa_patch " i read further to see: #addtask qa_configure after do_configure before do_compile do_configure[postfuncs] += "do_qa_configure " and concluded that, once upon a time, qa_configure *used* to be a task, then it was downgraded to just a non-task function but it wasn't worth the churn to rename. that change goes *way* back to 2011 (if anyone cares): $ git show 1efeeecc338 i just wanted to clarify that there wasn't something subtle going on here, and standard OE coding style normally reserves "do_"-prefixed functions strictly for tasks. rday
-=-=-=-=-=-=-=-=-=-=-=- Links: You receive all messages sent to this group. View/Reply Online (#239884): https://lists.openembedded.org/g/openembedded-core/message/239884 Mute This Topic: https://lists.openembedded.org/mt/120045207/21656 Group Owner: [email protected] Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [[email protected]] -=-=-=-=-=-=-=-=-=-=-=-
