On Thu, 2026-09-03 at 12:18 +0100, Richard Purdie wrote: > On Sun, 2026-08-30 at 23:48 +0200, Adrian Freihofer via > lists.openembedded.org wrote: > > From: Adrian Freihofer <[email protected]> > > > > With usrmerge in DISTRO_FEATURES (the default), root_prefix becomes > > exec_prefix, so base_libdir and libdir resolve to the same path. > > This > > made most entries of solib_search_path() literal duplicates. Dedupe > > while preserving order. > > > > Signed-off-by: Adrian Freihofer <[email protected]> > > --- > > scripts/lib/devtool/ide_sdk.py | 3 ++- > > 1 file changed, 2 insertions(+), 1 deletion(-) > > > > diff --git a/scripts/lib/devtool/ide_sdk.py > > b/scripts/lib/devtool/ide_sdk.py > > index 4fdeeec24d..6f08940c9c 100755 > > --- a/scripts/lib/devtool/ide_sdk.py > > +++ b/scripts/lib/devtool/ide_sdk.py > > @@ -643,7 +643,8 @@ class RecipeModified: > > os.path.join(image.rootfs, base_libdir), > > os.path.join(image.rootfs, libdir) > > ] > > - return so_paths > > + # base_libdir == libdir when usrmerge is in > > DISTRO_FEATURES (the default), dedupe > > + return list(dict.fromkeys(so_paths)) > > This is a little hard to read, would set(so_paths) work here?
The order of these paths is essential. Therefore set would not work. I'm working on a v3 which will improve the comments for this complicated function as much as possible. Thanks you Regards, Adrian > > Cheers, > > Richard
-=-=-=-=-=-=-=-=-=-=-=- Links: You receive all messages sent to this group. View/Reply Online (#245034): https://lists.openembedded.org/g/openembedded-core/message/245034 Mute This Topic: https://lists.openembedded.org/mt/121005241/21656 Group Owner: [email protected] Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [[email protected]] -=-=-=-=-=-=-=-=-=-=-=-
