On 07/04/2016 10:14 AM, Benjamin Esquivel wrote:
Hello Mariano, comments below

  class ExportTestContext(RuntimeTestContext):
-    def __init__(self, d, target, exported=False):
+    def __init__(self, d, target, exported=False, *args, **kwargs):
Is the use of kwargs necessary? If not, it would be preferable to have a
Named var here instead. Kwargs breaks readability.

Is not really necessary at this point. The idea here was to be easier to extend the class in child classes, but I see your point with the kwargs being to generic.

      target.exportStart()
-    tc = ExportTestContext(d, target, True)
+    tc = ExportTestContext(d, target, True, **kwargs)
If you don't want to mess with the inputs of this function by using kwargs
then you can consider passing an object that includes the variables you want. 
I'd
only suggest it if this function signature will grow.


Right now, it just require a single variable that is an argument from the cli, so I will use a dict for that purpose, per our discussion.

--
Mariano Lopez
--
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Reply via email to