* otherwise chromium-wayland recipe might build with CHROMIUM_ENABLE_WAYLAND 0 
and then
  autodetect couple of x11 libraries
  chromium-wayland-48.0.2548.0: chromium-wayland rdepends on atk, but it isn't 
a build dependency, missing atk in DEPENDS or PACKAGECONFIG? [build-deps]
  chromium-wayland-48.0.2548.0: chromium-wayland rdepends on gdk-pixbuf, but it 
isn't a build dependency, missing gdk-pixbuf in DEPENDS or PACKAGECONFIG? 
[build-deps]
  chromium-wayland-48.0.2548.0: chromium-wayland rdepends on gtk+, but it isn't 
a build dependency, missing gtk+ in DEPENDS or PACKAGECONFIG? [build-deps]
  chromium-wayland-48.0.2548.0: chromium-wayland rdepends on libxcomposite, but 
it isn't a build dependency, missing libxcomposite in DEPENDS or PACKAGECONFIG? 
[build-deps]
  chromium-wayland-48.0.2548.0: chromium-wayland rdepends on libxcursor, but it 
isn't a build dependency, missing libxcursor in DEPENDS or PACKAGECONFIG? 
[build-deps]
  chromium-wayland-48.0.2548.0: chromium-wayland rdepends on libxscrnsaver, but 
it isn't a build dependency, missing libxscrnsaver in DEPENDS or PACKAGECONFIG? 
[build-deps]

* reported a while ago in:
  
http://lists.openembedded.org/pipermail/openembedded-devel/2016-September/109131.html

Signed-off-by: Martin Jansa <martin.ja...@gmail.com>
---
 recipes-browser/chromium/chromium-wayland_48.0.2548.0.bb | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/recipes-browser/chromium/chromium-wayland_48.0.2548.0.bb 
b/recipes-browser/chromium/chromium-wayland_48.0.2548.0.bb
index f7ad2ce..bbba147 100644
--- a/recipes-browser/chromium/chromium-wayland_48.0.2548.0.bb
+++ b/recipes-browser/chromium/chromium-wayland_48.0.2548.0.bb
@@ -28,6 +28,8 @@ python() {
     if (d.getVar('CHROMIUM_ENABLE_WAYLAND', True) == '1'):
         if bb.utils.contains('PACKAGECONFIG', 'component-build', True, False, 
d):
             bb.fatal("Chromium 48 Wayland version cannot be built in 
component-mode")
+    else:
+        raise bb.parse.SkipPackage("CHROMIUM_ENABLE_WAYLAND isn't enabled")
 }
 
 CHROMIUM_WAYLAND_GYP_DEFINES = "use_ash=1 use_aura=1 chromeos=0 use_ozone=1 
use_xkbcommon=1"
-- 
2.10.1

-- 
_______________________________________________
Openembedded-devel mailing list
Openembedded-devel@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-devel

Reply via email to