On Fri, Nov 18, 2016 at 11:26 AM, Koen Kooi <[email protected]> wrote:
> -    if [ grep -q "ext4_utils" "${TOOLS}" ] ; then
> +    export TOOLSFILE="${WORKDIR}/tools.txt"
> +    echo ${TOOLS} > ${TOOLSFILE}
> +
> +    if grep -q "ext4_utils" ${TOOLSFILE} ; then


how about this instead?

echo  "${TOOLS}" | grep -q "ext4_utils"

it looks simpler and more readable to me.
-- 
_______________________________________________
Openembedded-devel mailing list
[email protected]
http://lists.openembedded.org/mailman/listinfo/openembedded-devel

Reply via email to