Hello Khem

Are you saying that  libanthy-dev is not need and anthy only is sufficient?

anthy is in DEPENDS already. BUT it is not sufficient.
If libanthy-dev is not in DEPENDS_class-target, do_configure will not be
failed.

However config.log say like as follows:

-----
configure:20054: checking anthy/anthy.h usability
configure:20054: i586-poky-linux-gcc -m32 -march=i586
--sysroot=/home/y-mitsuki/yocto/build_keyboard/tmp/work/i586
-poky-linux/uim/1.8.6-r0/recipe-sysroot -c  -O2 -pipe -g
-feliminate-unused-debug-types -fdebug-prefix-map=/home/y-mit
suki/yocto/build_keyboard/tmp/work/i586-poky-linux/uim/1.8.
6-r0=/usr/src/debug/uim/1.8.6-r0 -fdebug-prefix-map=/home/y-mit
suki/yocto/build_keyboard/tmp/work/i586-poky-linux/uim/1.8.6-r0/recipe-sysroot-native=
-fdebug-prefix-map=/home/y-mitsuki/yocto/build_keyboard/tmp/
work/i586-poky-linux/uim/1.8.6-r0/recipe-sysroot=   conftest.c >&5
conftest.c:65:25: fatal error: anthy/anthy.h: No such file or directory
#include <anthy/anthy.h>
-----

Then uim-anthy is not created.
In order to build uim-anthy, anthy.h is need but it is not installed into
recipes-sysroot.
anthy.h is incluced libanthy-dev not anthy.

Therefor I think libanthy-dev is need.

Let me know you opinions?




2017-08-08 12:48 GMT+09:00 Khem Raj <raj.k...@gmail.com>:

>
> On Mon, Aug 7, 2017 at 6:00 PM Yusuke Mitsuki <
> mickey.happygolu...@gmail.com> wrote:
>
>> anthy.h could not found at confiugre of uim.
>> Dependency broke since it began to use recipes-sysroot.
>>
>> Signed-off-by: Yusuke Mitsuki <mickey.happygolu...@gmail.com>
>> ---
>>  meta-oe/recipes-support/anthy/anthy_9100h.bb | 1 +
>>  meta-oe/recipes-support/uim/uim_1.8.6.bb     | 2 +-
>>  2 files changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/meta-oe/recipes-support/anthy/anthy_9100h.bb
>> b/meta-oe/recipes-support/anthy/anthy_9100h.bb
>> index a65d324..c507ad7 100644
>> --- a/meta-oe/recipes-support/anthy/anthy_9100h.bb
>> +++ b/meta-oe/recipes-support/anthy/anthy_9100h.bb
>> @@ -18,6 +18,7 @@ SRC_URI[sha256sum] = "d256f075f018b4a3cb0d165ed6151f
>> da4ba7db1621727e0eb54569b6e2
>>
>>  DEPENDS_class-target = "anthy-native"
>>  RDEPENDS_${PN}_class-target = "libanthy0"
>> +PROVIDES_class-target = "libanthy-dev"
>
>
> This seems redundant
>
>
>>
>>  inherit autotools pkgconfig
>>
>> diff --git a/meta-oe/recipes-support/uim/uim_1.8.6.bb
>> b/meta-oe/recipes-support/uim/uim_1.8.6.bb
>> index ed846b9..4cb7b62 100644
>> --- a/meta-oe/recipes-support/uim/uim_1.8.6.bb
>> +++ b/meta-oe/recipes-support/uim/uim_1.8.6.bb
>> @@ -14,7 +14,7 @@ SRC_URI[md5sum] = "ecea4c597bab1fd4ba98ea84edcece59"
>>  SRC_URI[sha256sum] = "7b1ea803c73f3478917166f04f67cc
>> e6e45ad7ea5ab6df99b948c17eb1cb235f"
>>
>>  DEPENDS = "anthy fontconfig libxft libxt glib-2.0 ncurses intltool"
>> -DEPENDS_class-target += "intltool-native gtk+ gtk+3 uim-native
>> takao-fonts"
>> +DEPENDS_class-target += "intltool-native gtk+ gtk+3 uim-native
>> takao-fonts libanthy-dev"
>>
>
> It should say anthy not libanthy-dev
>
>>
>>  RDEPENDS_uim = "libuim0 libedit"
>>  RDEPENDS_uim-anthy = "takao-fonts anthy libanthy0"
>> --
>> 2.7.4
>>
>> --
>> _______________________________________________
>> Openembedded-devel mailing list
>> Openembedded-devel@lists.openembedded.org
>> http://lists.openembedded.org/mailman/listinfo/openembedded-devel
>>
>
-- 
_______________________________________________
Openembedded-devel mailing list
Openembedded-devel@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-devel

Reply via email to