From: Stefan Agner <stefan.ag...@toradex.com>

RapidJSON is a header only library. The automatic package split
leads to no 'rapidjson' package but a 'rapidjson-dev' package with
a dependency to the 'rapidjson' package, leading to errors like:
 * Solver encountered 1 problem(s):
 * Problem 1/1:
 *   - nothing provides rapidjson = 1.1.0+git0+e5635fb27f-r0 needed by 
rapidjson-dev-1.1.0+git0+e5635fb27f-r0.core2-64

Clear rapidjson-dev dependencies.

Signed-off-by: Stefan Agner <stefan.ag...@toradex.com>
---
 meta-oe/recipes-devtools/rapidjson/rapidjson_git.bb | 1 +
 1 file changed, 1 insertion(+)

diff --git a/meta-oe/recipes-devtools/rapidjson/rapidjson_git.bb 
b/meta-oe/recipes-devtools/rapidjson/rapidjson_git.bb
index 4cded07..8ab35d2 100644
--- a/meta-oe/recipes-devtools/rapidjson/rapidjson_git.bb
+++ b/meta-oe/recipes-devtools/rapidjson/rapidjson_git.bb
@@ -21,5 +21,6 @@ EXTRA_OECMAKE += "-DRAPIDJSON_BUILD_DOC=OFF 
-DRAPIDJSON_BUILD_TESTS=OFF -DRAPIDJ
 # RapidJSON is a header-only C++ library, so the main package will be empty.
 
 FILES_${PN}-dev += "${libdir}/cmake"
+RDEPENDS_${PN}-dev = ""
 
 BBCLASSEXTEND = "native nativesdk"
-- 
2.7.4

-- 
_______________________________________________
Openembedded-devel mailing list
Openembedded-devel@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-devel

Reply via email to