The failures appeared with recent gtk-doc 1.27 update in oe-core.

Signed-off-by: Alexander Kanavin <alexander.kana...@linux.intel.com>
---
 meta-gnome/recipes-gnome/libgdata/libgdata_0.16.1.bb | 4 ++++
 meta-oe/recipes-gnome/libunique/libunique_1.1.6.bb   | 2 +-
 2 files changed, 5 insertions(+), 1 deletion(-)

diff --git a/meta-gnome/recipes-gnome/libgdata/libgdata_0.16.1.bb 
b/meta-gnome/recipes-gnome/libgdata/libgdata_0.16.1.bb
index c2157df0c..9b025128b 100644
--- a/meta-gnome/recipes-gnome/libgdata/libgdata_0.16.1.bb
+++ b/meta-gnome/recipes-gnome/libgdata/libgdata_0.16.1.bb
@@ -15,6 +15,10 @@ do_configure_prepend_class-target () {
     # introspection.m4 pre-packaged with upstream tarballs does not yet
     # have our fixes
     rm -f ${S}/introspection.m4
+    
+    # remove the pre-built gtk-doc files, as they're installed (or attempted 
to be installed)
+    # even if gtk-doc is explicitly disabled
+    rm -rf ${S}/docs/reference/html
 }
 
 do_compile_prepend() {
diff --git a/meta-oe/recipes-gnome/libunique/libunique_1.1.6.bb 
b/meta-oe/recipes-gnome/libunique/libunique_1.1.6.bb
index 9133cccb1..49ed07ad9 100644
--- a/meta-oe/recipes-gnome/libunique/libunique_1.1.6.bb
+++ b/meta-oe/recipes-gnome/libunique/libunique_1.1.6.bb
@@ -25,6 +25,6 @@ LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
 
 
-inherit autotools pkgconfig gobject-introspection distro_features_check
+inherit autotools pkgconfig gobject-introspection distro_features_check gtk-doc
 
 REQUIRED_DISTRO_FEATURES = "x11"
-- 
2.15.1

-- 
_______________________________________________
Openembedded-devel mailing list
Openembedded-devel@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-devel

Reply via email to