* sneaked in with:
  commit 333949a8239dfa7788b35f1059614733e11a6a25
  Author: Samuli Piippo <samuli.pii...@qt.io>
  Date:   Thu Jan 26 16:54:50 2017 +0200

    Upgrade to Qt 5.8
* use 5.10.1 branch by defaut and fix QT_MODULE_BRANCH
  in qtknx, qtmqtt, qtwebkit-examples, qtwebkit which don't
  have 5.10.1 branch at all

Signed-off-by: Martin Jansa <martin.ja...@gmail.com>
---
 recipes-qt/qt5/qt5-git.inc              | 6 +++---
 recipes-qt/qt5/qtknx_git.bb             | 2 ++
 recipes-qt/qt5/qtmqtt_git.bb            | 2 ++
 recipes-qt/qt5/qtwebkit-examples_git.bb | 2 ++
 recipes-qt/qt5/qtwebkit_git.bb          | 2 ++
 5 files changed, 11 insertions(+), 3 deletions(-)

diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 7ee0643..beba913 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -1,9 +1,9 @@
 # Copyright (C) 2012-2016 O.S. Systems Software LTDA.
-# Copyright (C) 2013-2017 Martin Jansa <martin.ja...@gmail.com>
+# Copyright (C) 2013-2018 Martin Jansa <martin.ja...@gmail.com>
 
 QT_MODULE ?= "${BPN}"
-QT_MODULE_BRANCH ?= "5.10"
-QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH};nobranch=1"
+QT_MODULE_BRANCH ?= "5.10.1"
+QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH}"
 
 # each module needs to define valid SRCREV
 SRC_URI = " \
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb
index 5e01e3c..fa981ab 100644
--- a/recipes-qt/qt5/qtknx_git.bb
+++ b/recipes-qt/qt5/qtknx_git.bb
@@ -9,4 +9,6 @@ LIC_FILES_CHKSUM = " \
 
 DEPENDS += "qtbase"
 
+QT_MODULE_BRANCH = "5.10"
+
 SRCREV = "29c34e8f072afd01002ed3847d752b4e065f977e"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index b705f7c..90c255d 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,6 @@ LIC_FILES_CHKSUM = " \
 
 DEPENDS += "qtbase"
 
+QT_MODULE_BRANCH = "5.10"
+
 SRCREV = "2c3c2a41c55a179332ec2a076856990f36dd5ef9"
diff --git a/recipes-qt/qt5/qtwebkit-examples_git.bb 
b/recipes-qt/qt5/qtwebkit-examples_git.bb
index 3e3e4a0..114fab7 100644
--- a/recipes-qt/qt5/qtwebkit-examples_git.bb
+++ b/recipes-qt/qt5/qtwebkit-examples_git.bb
@@ -17,4 +17,6 @@ DEPENDS += "qtwebkit qtxmlpatterns"
 RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins"
 RDEPENDS_${PN}-examples += "${@bb.utils.contains('PACKAGECONFIG_OPENSSL', 
'openssl', 'ca-certificates', '', d)}"
 
+QT_MODULE_BRANCH = "5.9"
+
 SRCREV = "a24c780b60d7d8bc00c4a48042cf7f32db777d55"
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 5dee6a4..b23d4d6 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -87,4 +87,6 @@ PACKAGES_remove = "${PN}-examples-dev 
${PN}-examples-staticdev ${PN}-examples-db
 RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 
'i386').replace('i686', 'i386') }"
 export 
RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}"
 
+QT_MODULE_BRANCH = "5.9"
+
 SRCREV = "97c4a80a1282c8c3eaa343011286b76fd4838c5f"
-- 
2.15.1

-- 
_______________________________________________
Openembedded-devel mailing list
Openembedded-devel@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-devel

Reply via email to