On 01/13/17 05:20 PM, Carsten Grzemba wrote:

I solved the problem by
- set non-sticky the openindiana.org publisher
- create a fake repo and publish there incorporation packages where dependency 
type is changed to optional, remove the obsoleted flag in dhcp package
# pkgrepo list -s /repos/fake-hipster/
PUBLISHER NAME O VERSION
fake-hipster consolidation/install/install-incorporation 
0.5.11,5.11-0.151.1.9:20170108T144721Z
fake-hipster consolidation/ips/ips-incorporation 
0.5.11,5.11-0.151.1.9:20170111T153531Z
fake-hipster consolidation/osnet/osnet-incorporation 
0.5.11,5.11-0.151.1.9:20170108T132101Z
fake-hipster service/network/dhcp 0.5.11,5.11-2015.0.2.15619:20170113T123056Z
fake-hipster service/network/dhcp 0.5.11,5.11-0.151.1.9:20170106T113837Z
- add the fake-hipster repository to search before openindiana.org publisher
- at first replace (pkg update) the old incorporations with the old fake 
incorporation (optional dependencies)
- remove the fake repository
- do a normal upgrade to the latest hipster


Do later SRSS versions come as IPS packages? When I installed it last time, they were still SVR4-packaged, so IPS wouldn't be aware of it...

--
Best regards,
Alexander Pyhalov,
system administrator of Southern Federal University IT department

_______________________________________________
openindiana-discuss mailing list
openindiana-discuss@openindiana.org
https://openindiana.org/mailman/listinfo/openindiana-discuss

Reply via email to