Hi.

I am stuck on a issue with locale not working.
It was discovered when pkg started issuing the following messages on
invocation:
# pkg search -rp rcs
pkg: Unable to set locale; locale package may be broken or
not installed.  Reverting to C locale.
PACKAGE                                     PUBLISHER
...

Also perl does not like it..
perl -v
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LC_ALL = (unset),
        LC_MONETARY = "en_US.UTF-8",
        LC_COLLATE = "en_US.UTF-8",
        LC_CTYPE = "UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LC_MESSAGES = "C",
        LC_TIME = "en_US.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
This is perl 5, version 22, subversion 4 (v5.22.4) built for
i86pc-solaris-64int

locale -a shows i have en_US.UTF-8 installed
i have the following locale packages installed (and reinstalled)
local/en
text/locale
system/locale/support/english
system/install/locale

My /etc/default/init include:
TZ=Europe/Copenhagen
LANG=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_CTYPE="en_US.UTF-8"
LC_MESSAGES="C"
LC_MONETARY="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"

But still locale returns:
# locale
LANG=en_US.UTF-8
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES=C
LC_ALL=

Any ideas on I reinitialize locale to fix this ?


Thanks
Flemming
_______________________________________________
openindiana-discuss mailing list
openindiana-discuss@openindiana.org
https://openindiana.org/mailman/listinfo/openindiana-discuss

Reply via email to