On Sun, Apr 29, 2018 at 12:56 PM, Till Wegmüller <toaster...@gmail.com>
wrote:

> Hello Dear OI Community
>
> I am trying to connect my Ultimaker to my OpenIndiana Server. It is a
> serial device accessed through a python software.
>
> When connecting the USB I can see it showing up in dmesg:
> Apr 29 11:34:36 node02 usba: [ID 349649 kern.info] usba:        no
> driver found for interface 1 (nodename: 'data') of Ultimaker BV
> (www.ultimaker.com) Ultimaker 2.0
> Apr 29 11:34:36 node02 usba: [ID 912658 kern.info] USB 1.10 interface
> (usbif2341,10.config1.0) operating at full speed (USB 1.x) on USB 3.0
> root hub: modem@0, usbsacm1 at bus address 2
> Apr 29 11:34:36 node02 usba: [ID 349649 kern.info] Ultimaker BV
> (www.ultimaker.com) Ultimaker 2.0
> Apr 29 11:34:36 node02 genunix: [ID 936769 kern.info] usbsacm1 is
> /pci@0,0/pci1043,84ca@14/communications@1/modem@0
> Apr 29 11:34:36 node02 genunix: [ID 408114 kern.info]
> /pci@0,0/pci1043,84ca@14/communications@1/modem@0 (usbsacm1) online
>
> But I do not know where that file would be under /dev. On linux it's
> somewhere under /dev/ttyUSB or /dev/ttyACM.
>
> I have a device under /dev/term that links to
> ../../devices/pci@0,0/pci1043,84ca@14/communications@1/modem@0:0 like
> usbsacm1 should. But that device seems not to be correct.
>
> Does anybody know where that device usbsacm1 would be under /dev? or do
> I need anything aditional to get access to that device?
>

Is there anything in /dev/cua ? (There should be an equivalent in there
to the device in /dev/term.)

-- 
-Peter Tribble
http://www.petertribble.co.uk/ - http://ptribble.blogspot.com/
_______________________________________________
openindiana-discuss mailing list
openindiana-discuss@openindiana.org
https://openindiana.org/mailman/listinfo/openindiana-discuss

Reply via email to