Bump... Still a problem on the latest Ubuntu machines (fully patched):

   $ lsb_release -a
   No LSB modules are available.
   Distributor ID: Ubuntu
   Description: Ubuntu 16.04.4 LTS
   Release: 16.04
   Codename: xenial

And:

   $ sudo apt-get install openjdk-9-jdk
   Reading package lists... Done
   Building dependency tree
   Reading state information... Done
   Suggested packages:
     openjdk-9-demo openjdk-9-source visualvm
   The following NEW packages will be installed:
     openjdk-9-jdk
   0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
   12 not fully installed or removed.
   Need to get 0 B/16.6 kB of archives.
   After this operation, 58.4 kB of additional disk space will be used.
   (Reading database ... 198589 files and directories currently installed.)
   Preparing to unpack .../openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb ...
   Unpacking openjdk-9-jdk:amd64 (9~b114-0ubuntu1) ...
   dpkg: error processing archive 
/var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb (--unpack):
    trying to overwrite 
'/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in 
package openjdk-9-jdk-headless:amd64 9~b114-0ubuntu1
   Errors were encountered while processing:
    /var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb
   E: Sub-process /usr/bin/dpkg returned an error code (1)

-- 
You received this bug notification because you are a member of OpenJDK,
which is subscribed to openjdk-9 in Ubuntu.
https://bugs.launchpad.net/bugs/1550950

Title:
  package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying to
  overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h',
  which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1

Status in One Hundred Papercuts:
  New
Status in openjdk-9 package in Ubuntu:
  Fix Released
Status in openjdk-9 source package in Xenial:
  Fix Released

Bug description:
  Ubuntu Xenial Xerus (development branch)

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: openjdk-9-jdk 9~b102-1
  ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
  Uname: Linux 4.4.0-8-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  Date: Sun Feb 28 16:44:30 2016
  ErrorMessage: trying to overwrite 
'/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in 
package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1
   apt  1.2.3
  SourcePackage: openjdk-9
  Title: package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying to 
overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is 
also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/hundredpapercuts/+bug/1550950/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~openjdk
Post to     : openjdk@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openjdk
More help   : https://help.launchpad.net/ListHelp

Reply via email to