Glad this solved your problem. I added "SP1" to the Wiki page.

-- Kevin

Michael Berry wrote:
Hi Kevin,

Many thanks for that - that has solved the problem! Perhaps the wiki page <> should be updated to note that SP1 should be installed as well as vanilla VS2010? I would do it myself, but don't have the privileges.



On 22 March 2014 14:46, Kevin Rushforth < <>> wrote:

    Do you have VS 2010 Service Pack 1? I've seen this failure on
    machines that don't have SP1 installed.

    -- Kevin

    Michael Berry wrote:

    I'm currently trying to build OpenJFX from source on Windows - I've
    followed the instructions on the build page and have Visual Studio 2010,
    the June 2010 directx sdk, cygwin and its relevant modules installed.
    However, when building it fails at the buildJavaFXPackage task (output

    I'm not sure if those warnings are normal or not, but they definitely look
    suspicious. It seems the actual error that's stopping things is the "fatal
    error LNK1123: failure during conversion to COFF: file invalid or corrupt"
    line, though all I've found searching around for that error is that
    "incremental:off" should be set to avoid it, which it already is in the
    gradle task.

    Any ideas?



    : warning C4018: '<' : signed/unsigned mismatch
    : warning C4018: '<' : signed/unsigned mismatch
    : warning C4018: '<' : signed/unsigned mismatch
    : warning C4996: 'getenv': This function or variable may be unsafe.
    Consider using _dupenv_s instead. To disable deprecation,use
    _CRT_SECURE_NO_WARNINGS. See online help for details.
            C:/Program Files (x86)/Microsoft Visual Studio
    10.0/VC/INCLUDE\stdlib.h(433) : see declaration of 'getenv'LINK : fatal
    error LNK1123: failure during conversion to COFF: file invalid or corrupt
    :fxpackager:buildJavaFXPackager FAILED

    FAILURE: Build failed with an exception.

    * Where:
    Build file 'C:\Users\Michael\Documents\JFX8-dev\build.gradle' line: 1817

    * What went wrong:
    Execution failed for task ':fxpackager:buildJavaFXPackager'.
    Process 'command 'C:/Program Files (x86)/Microsoft Visual Studio
    10.0/VC/BIN/link.exe'' finished with non-zero exit value 1123

Reply via email to