On Mon, 24 Feb 2020 11:09:30 GMT, dannygonzalez 
<github.com+6702882+dannygonza...@openjdk.org> wrote:

>> Agreed, will change.
> 
> Nope, actually:
> `listeners.keySet().removeIf(p::test) `
> 
> is not the same as:
> `listeners.entrySet().removeIf(e -> p.test(e.getKey()));`
> 
> We need to test against the entrySet.key not the entrySet itself.

> We need to test against the entrySet.key not the entrySet itself.

I suggested to test against the elements in `keySet()`, which are the same as 
the ones in `entrySet().getKey()`.

-------------

PR: https://git.openjdk.java.net/jfx/pull/108

Reply via email to