On Tue, 21 Sep 2021 12:45:20 GMT, Kevin Rushforth <k...@openjdk.org> wrote:
> As mentioned in JBS, the `clearQuad` methods in `D3DGraphics` and > `ES2Graphics` are now identical, which should have been the case all along. > The fact that they weren't identical was the source of a bug that was only > discovered during the testing of > [JDK-8090547](https://bugs.openjdk.java.net/browse/JDK-8090547) on the es2 > pipeline. > > This PR moves the `clearQuad` method to the `BaseShaderGraphics` superclass > to get rid of the unnecessary code duplication. This will be helpful when > implementing the metal pipeline as well. As a note, I made the `context` > field in the `D3DGraphics` final, which it should have been. This is > necessary to ensure that moving the method to the super-class is equivalent. > > No new tests are needed, since this is just refactoring. This pull request has now been integrated. Changeset: 338b9994 Author: Kevin Rushforth <k...@openjdk.org> URL: https://git.openjdk.java.net/jfx/commit/338b999414ed5dc8fea19c12bd3e656fd9cab6f4 Stats: 59 lines in 3 files changed: 18 ins; 40 del; 1 mod 8273946: Move clearQuad method to BaseShaderGraphics superclass Reviewed-by: jpereda, nlisker ------------- PR: https://git.openjdk.java.net/jfx/pull/628