On Fri, 2 Feb 2024 13:27:50 GMT, John Hendrikx <jhendr...@openjdk.org> wrote:

> My conclusion is that we either need two rounds to get this right (to first 
> free up our first choice getStyleClasses), or we can settle on one of: 
> getStyleClassNames, getStyles, getStyleNames, getClasses, getClassNames.

Let's settle on one of these names. I think `getClasses` is fine. My second 
choice would be `getClassNames`.

There is one other method used by SceneBuilder's `CssInternal` class, 
`CompoundSelector::getSelectors`. I think you need to add a method to the 
`Selector` base class that returns a `List<Selector>` instead of the 
`List<SimpleSelector>` returned by the existing `CompoundSelector` method. 
Maybe `getChildSelectors` or similar? That method would be overridden in the 
subclasses with `CompoundSelector` wrapping the existing selectors list in an 
unmodifiable list and `SimpleSelectors` returning an empty List.

-------------

PR Comment: https://git.openjdk.org/jfx/pull/1340#issuecomment-1924164069

Reply via email to