On Thu, 25 Apr 2024 15:20:54 GMT, Nir Lisker <nlis...@openjdk.org> wrote:

>> JFX minimum requirements guarantee 9Ex availability, so old non-Ex paths are 
>> no longer needed.
>> 
>> In multiple parts (ex. Mesh, Graphics, etc.) where the Device is acquired I 
>> changed the type to explicitly use `IDirect3DDevice9Ex`. Technically it 
>> doesn't matter much (`IDirect3DDevice9Ex` inherits `IDirect3DDevice` - it 
>> was leveraged to transparently use the Ex device in the backend) but now we 
>> don't have the non-Ex device, so that keeps it a bit more consistent and 
>> clear IMO.
>> 
>> Verified by running tests on Windows 11, did not notice any regressions. 
>> Unfortunately I have no way to test this on older systems.
>
> modules/javafx.graphics/src/main/native-prism-d3d/D3DPipeline.cc line 237:
> 
>> 235: }
>> 236: 
>> 237: int getMaxSampleSupport(IDirect3D9Ex *d3d9, UINT adapter) {
> 
> Minor: In some cases you also change the name of the variable to add the "Ex" 
> suffix., like in
> 
> D3DContext::D3DContext(IDirect3D9Ex *pd3dEx, UINT adapter)
>                                          ^
> 
> Here and In `PiplineManager.h` it's left as `IDirect3D9Ex * pd3d9;` without 
> "Ex".
> I don't mind it either way (I would probably not bother changing them 
> myself), but perhaps we should remain consistent.

You're right. Most places use it as `pd3d9` so I'll leave it this way (remove 
the `Ex` suffix from other spots).

-------------

PR Review Comment: https://git.openjdk.org/jfx/pull/1445#discussion_r1580608891

Reply via email to